SAP Knowledge Base Article - Public

2993873 - Cannot edit most fields in "Manage Recurring Supplier Invoices" app

Symptom

For a created recurring supplier invoice in "Manage Recurring Supplier Invoices" app, most fields, like "Gross Invoice Amount" and "Reference", cannot be changed. Also an attachment cannot be added to the invoice.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open "Manage Recurring Supplier Invoices" app.
  2. Select a recurring supplier invoice.
  3. Click the "Edit" button at the top right of the page.
  4. Most input fields cannot be changed and an attachment cannot be added.

Cause

The recurring supplier invoice that is expected to be edited has been partly posted.

Resolution

If real supplier invoices have been created from the recurring supplier invoice, then only some fields in "Recurrence" section are editable.

Different from the "Manage Recurring Journal Entries" app, this is the standard behavior of "Manage Recurring Supplier Invoices" app. As a recurring supplier invoice is regarded as the original document for the real supplier invoices generated, the purpose is to keep the original document aligned with the invoices that are generated from this app.

Keywords

Manage Recurring Supplier Invoices, F4312, Edit, Posted, Recurrence, Attachment, Consistent , KBA , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions