SAP Knowledge Base Article - Public

2997333 - Email notifications are sent with wrong locale - Onboarding

Symptom

Emails that are configured in Email Services set for onboardees are not respecting the default locale of the receiver.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Send an Onboarding Email from Email Services
  2. Receiver should have a different local
  3. Email that will be received will show as English (or depending on the default locale of the environment)

Cause

This is happening due the rules in the Email Template in Email Services is either not present or misconfigured.

If there are no rules that are set here, the system will follow the default locale set on the environment.

Resolution

In order to solve, please follow:

  1. Go to Admin Center -> Email Services
  2. Manage Email Template -> Choose the email template
  3. Click on Step 2
  4. Double check your configuration in E. Language Selection Business Rule

See Also

2905960 - [HOW TO] Add an existing email template to the active list in Email Services - Onboarding 2.0

2921186 - DayOneLocation token is not being populated in email services - Onboarding 2.0

Keywords

Onb, Email, Services, Locale, Language, Selection, Business, Rule, Onboarding, Obx , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions