SAP Knowledge Base Article - Public

2997407 - Outbound Call Is Not Getting Triggered To The External Client

Symptom

Customer has a SAPCODCTIConnector.dll file in order to further enable the outbound calling feature in SAP Cloud for Customer. Outbound call is triggered and a pop up is shown in C4C UI but no calls go to the customer.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customer Workcenter.
  2. Then to Contacts View.
  3. In the Contact OWL, click on any available Phone or Mobile number link, so that an Outbound Call is Triggered from C4C.

A pop up is shown in the UI but no Logs are generated in the SAP CTI Adapter and in turn in the DLL file. The Dial Out logic written in dll file is not triggering the call to the External Client.

Cause

Sometimes,the SAPCODCTIConnector.dll file deployed at the Customer System will be blocked by Windows as a part of their Security Policy.

Resolution

  1. Go to the File Path where the SAPCODCTIConnector.dll  file is deployed in the Customer System.
  2. Then Right Click on SAPCODCTIConnector.dll and go to Properties.
  3. You could see as in the attached screenshot, that the DLL execution was blocked by the Windows.

Kindly click on Unblock and save the changes. Now on triggering an outbound call,the External Client should receive the same.

CTI_DLL_Unblock.png

See Also

https://help.sap.com/viewer/5d3ae4aa1f174b2cb6ec625c93ef8884/2002/en-US/281b7d35a520464f942b3b34692c045d.html

Keywords

Outbound call, CTI, SAPCODCTIConnector.dll , Dial Out logic, , KBA , outboundcallhandler.cs , unblock , windows , LOD-CRM-LA , Live Activity , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2008

Attachments

CTI_DLL_Unblock.png