Symptom
- HRIS Sync Job Failure Caused By Memory Cache Issue
- HRIS Sync Job failed and restart and run successfully
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
Employee central - Hris sync
Reproducing the Issue
Customer:
- Import task such as: Basic User Imports, API Upsert trigger one time Hris sync job
- schedule Hris Sync Job failed
- Result: Hris Sync Job response e-mail sent to customer or Job Owner
Normally the "Job Owner" of the job will receive an e-mail notification when the job is completed and it will give the status of "Successful", "Failed", "Interrupted".
Backend or Provisioning Information
- HRIS Sync job is failing - Provisioning > Monitor Jobs > filter on the second "HRIS Sync" in the list > check for failed jobs
- status: failed
- Click Detail: Caused by: java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: GC overhead limit exceeded
- After HRIS Sync job will restart and run successfully
Cause
- The job can fail to connect to database as a result of Memory Cache of Jboss Server being exceeded
- Caused by: java.util.concurrent.ExecutionException: java.lang.OutOfMemoryError: GC overhead limit exceeded
Resolution
Hris sync jobs failed because of DC(data center) performance Memory Cache Issue and the Hris sync job will restart internally by operation team at the Database level
If issue occurred very often,
Normally the "Job Owner" of the Hris job will receive an e-mail notification when the job is completed and it will give the status of "Successful", "Failed", "Interrupted". Also, if you check the "Details" of the job, you might see an Exception in the Details.
Note: As a customer, you don't have access to Provisioning. To complete tasks in Provisioning, contact your implementation partner.
If you're no longer working with an implementation partner, contact SAP Cloud Support.
- Run a one time full HRIS sync See: 2080728 - Employee Central: What is HRIS Sync?
- The jboss server will need to be restarted by ops team
@Employee Central Product Support: See internal memo for further guidance
FAQ - Additional Information
Q) Are there any Integrations (via API) setup to manipulate Basic User Data (UDF)?
A) Same as with Basic User Imports, if you have Integrations setup to feed data from a 3rd party system into Basic User Data, there is potential that you are overwriting the data synchronized by HRIS Sync.
Please refer to article 2080813 - HRIS Sync: Import & API upsert considerations - Employee Central - for more information and Here
EC Data Import or User Data Changes Through API
If there is at least one recurring HRIS Sync job configured in your company instance, an HRIS Element (Employee Central data) import triggers an HRIS Sync job run. This import of data can be from the UI or through API. Only one HRIS sync job can run at a time.
See Also
Keywords
ECT-87573, COSR-122272, SRSD-15869, Hris sync job, API, failed connect, database, Memory Cache, Jboss Server, COSD-14006, employee data import fail, long wait time, job recovered, cannot get db connection, Caused by: java.lang.OutOfMemoryError: GC overhead limit exceeded, performance, API, Hris sync, employee Data Import, OutOfMemoryError , KBA , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , LOD-SF-PLT-JOBS , Scheduled Jobs , Problem