Symptom
Error message " Item 50: Changing product type Service - fixed price without actuals not permitted " occurs when you try to change the Service ID/Product ID in the Sales Order
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to Sales Orders work center and Sales Orders View
- Search for Sales Order XXX(XXX is the ID of the Sales Order)
- Edit the Sales Orders and navigate to the Items tab
- Select the line Item 10 where the line item type
- Remove the Product ID YY and replace it with ZZ and you will get the error message (XX and YY are the IDs of the Product/Service)
- You will get error message " Item 10: Changing product type Service - fixed price without actuals not permitted "
Note : The issue occurs only if there is a Product ID with the same ID as Service ID
Cause
When a product ID is changed, the system checks if the product change is allowed, and to do this it first identifies the products in the system matching the product ID entered. If there is more than one product type matching the ID (for example, a material and a service), the system selects the item based on the document type. So going with the example of Sales Order XXX, and product ID ZZ, there is both a material and a service in your system with the ID ZZ. Since the document we are working on is a Sales Order, the system selects the material product, and then checks the applicability of this product based on the combination of sales org and distribution channel. Since the material ZZ is not available given the sales org and distribution channel mentioned in the sales order, the system displays the message that the item cannot be changed.
Resolution
The proper way to change an item in the Sales Order is to remove the existing item line first and then add the new product ID in a new item line. When this is done, the above mentioned checks do not apply and so the pre-selection of the material product type does not occur, meaning that the error does not occur.
Therefore, please remove the item that you want to replace and then add the product ID in a new line item. This will solve the problem.
Keywords
Product ID, Service ID , KBA , service id , product id , change product id , AP-SLO-SO , Sales Order , Problem