SAP Knowledge Base Article - Public

2998879 - Canvas Report Offline Export job fails due to Invalid row index and System.OutOfMemoryException

Symptom

  • When exporting a Canvas report Offline, the job fails with "Run Time Failure" status.  When viewing the Job Details in Report Center > View Schedules > My jobs, the following cause are indicated:
    • Encountered a problem while processing the download bundle. Timestamp: "YYYY-dd-mm hh:mm:ss". Detail : Invalid row index.
    • Encountered a problem while processing the download bundle. Timestamp: ""YYYY-dd-mm hh:mm:ss" ". Detail : Exception of type 'System.OutOfMemoryException' was thrown.
  • The job execution time as observed from Start Time and Finish Time details in Report Distributor is over 4-6 hours.
  • The report runs fine Online and has no issues.  

Environment

SAP SuccessFactors HCM Suite
Canvas
Online Report Designer

Reproducing the Issue

  1. Login and go to Report Center
  2. Search for affected Canvas report 
  3. Run it Online.
    Result: OK, Canvas displays data and report runs fine
  4. Now export the report to .xls or .xlsx format
    Result: Report job runs for some hours, e.g. 4-5 hours and eventually reaches Run Time Failure status in View Schedules > My Jobs


  5. Click on Actions > Job Details.  The following is indicated (may vary de
    Encountered a problem while processing the download bundle. Timestamp: "YYYY-dd-mm hh:mm:ss". Detail : Invalid row index.

    OR

    Encountered a problem while processing the download bundle. Timestamp: ""YYYY-dd-mm hh:mm:ss" ". Detail : Exception of type 'System.OutOfMemoryException' was thrown.

Cause

Huge volume of data returned by the report.  Over a million rows

Resolution

Detail : Invalid row index.
--> If you have selected the .xls or .xlsx format, this error means that the output has reached more than a million rows and exceeds .xlsx limitation.

For your reference here is the maximum number of rows a format can accomodate:

TypeCSVXLSXLSX
Microsoft Excel limitation in rows*No limit655361,048,576

Detail : Exception of type 'System.OutOfMemoryException' was thrown.
--> This other error means that since the report has run for a long time and has exceeded limits, the system ran out ot memory and terminated the job.

Proposed Solution:

To resolve this, either try CSV as an export format (no row limit) or much better narrow down the report scope by defining filters.  For example, you can test running this by entering a specific Employee ID (or Department, Workflow ID etc.)  in the Runtime Filter screen.  If the report has no Runtime filters, please edit it and specify static filters through Edit Query > Manage Filters.
If the export succeeds, then that shows that the output was too large.

See Also

2418819 - Reports Best Practices & Restrictions for Ad Hoc - ORD (Online and Offline capabilities)
https://launchpad.support.sap.com/#/notes/2418819

Keywords

invalid row index, run time failure, canvas export error, outofmemoryexception, report distributor failure, canvas job failed , KBA , LOD-SF-ANA-RDT , Report Distributor (Advanced Reporting, ORD) , Problem

Product

SAP SuccessFactors HXM Core 2005