Symptom
The Add button is missing in Revenue Schedule section in an opportunity.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open any Opportunity.
- Navigate to Revenue Splits tab.
- Under Revenue Split Partners, add at least one partner.
- Then in Revenue Schedule section, you find the Add button is missing here, although it's made visible in adaptation mode.
Cause
The Add button is invisible, since you have not marked the checkbox "Schedule Revenue at Header" in the opportunity header.
This is the explanation text of this checkbox:
"To enable revenue scheduling only at the header level, select this checkbox. To enable it only at the item level, de-select this checkbox. Caution: if you change this selection, you will delete existing schedules!"
Resolution
If you want to enable revenue scheduling only at the header level, enable this checkbox.
Note: If the checkbox "Schedule Revenue at Header" is not available in the opportunity header, make it visible through adaptation mode.
See Also
Help Portal documentation : Schedule Revenue
Keywords
Revenue Schedule, Add, Revenue Splits , KBA , LOD-CRM-OPP , Opportunity Management , How To