Symptom
Offline Pricing not working - Estimate price not pulled in Offline mode. Your user is set up for Offline Pricing and has sales data maintained.
Environment
SAP Sales Cloud
Reproducing the Issue
- In the C4C app, sync and go Offline.
- Go to the Customers work centre.
- Go to the Accounts view.
- Open any Account.
- Facet: Sales order.
- Click New.
- Add a product.
- Click Estimate Price -> nothing is entered.
Cause
The pricing procedure determination rules are maintained with value '*' present for Sales Org, Distribution Channel and Division. Using'*' here does not represent a wildcard character for 'select all', instead it means that the particular field should be blank.
Resolution
To fix this, please maintain proper values for Sales Org, Distribution Channel and Division in the determination rules as maintained in the sales area data for the user for which offline pricing is configured. The values for Sales Org and Distribution Channel should be same as the sales area data while the Division can vary.
- Go to the Business Configuration > Activity List.
- Offline Pricing Using External Pricing.
- Determine Pricing Procedure Rules.
Once this is done, please do a fresh offline sync and try out your scenario.
See Also
2671221 - Pricing Procedure Is Not Determined For Offline Pricing
Keywords
offline pricing, estimate price , KBA , LOD-CRM-PRC , C4C Pricing , Problem