Symptom
When trying to enroll to a scheduled program, where there is a class with the maximum registration reached, the system returns: The following class(s) have reached maximum registration.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Successfactors Learning
Reproducing the Issue
- Create a scheduled program > Add a blended/ILT course in it >
The item must be set "Yes" for the following:
- User can Self-Register.
- User can Request a Class.
- User can Waitlist.
- And the item maximum enrollments must be set. - Enroll users as an admin, so it would reach its maximum enrollments >
- Add the program to the users' library >
- As a user, go to library and try to enroll in the given program >
- The message is seen: "The following class(s) have reached maximum registration".
Cause
This is the current system design for scheduled programs. When the user tries to enroll in the program, where the class had its maximum registrations reached – even with the waitlist feature on, that message will return.
For programs under the open-ended and duration-based types, that validation message should not not return.
Resolution
To have a different system behavior, it would be possible to have an enhancement request (KBA 2090228) created for it, where the Learning Product Management team can further review and assess the requested functionality to be considered in a future release.
See Also
Keywords
The following class(s) have reached maximum registration, program, scheduled, enroll, error, class, User Can Waitlist, maximum, registration, waitlist, wait, list , KBA , LOD-SF-LMS-PRO , Programs , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-SCH , Class - Scheduled Offerings , LOD-SF-LMS-USR , User Entity , Problem