Symptom
- You observed that all user can see the competitor product, even though the competitor is assigned to a sales organization. It should not be accessible for all users.
- Since it is only possible to add sales organization to the the competitor, you assume that the access restrictions on competitor products is depending on the sales data of the linked own product when the own product was added/changed.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log in as user
- Go to Competitor work center
- Click on Competitor Product view
- Search for the relevant competitor product
Cause
There is no logic in place that the competitor product does get the ACL entries of the assigned competitor. Therefore, the assigned competitor does not inherit the sales data for access restrictions to the competitor product. Therefore, when sales data is changed on the linked own product, the access right on the competitor products related to it are not updated. If the sales data of the own product is changed after it was assigned to a competitor product, the competitor product still has the previous access rights. The sales areas of the assigned own product are also used to write ACL entries on competitor products. But this is only done when the competitor product is saved and own product is present and is based on the current state of active sales areas of own product.
Resolution
If the own product is changed later on (new sales area set active, blocked etc.) the competitor product's ACL is not updated. It is not recommended to rely on these restrictions. This is the expected system behaviour.
See Also
competitor products, comeptitor assigned to sales organziaiton, access restrictions, unrestricted access,
Keywords
KBA , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , Problem