Symptom
When checking a saved search, you note that there is at least one candidate returned. This same saved search is linked on a Talent Pool, but when accessing the Talent pool, there are no candidates listed.
***Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental***
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Create a Saved search under Recruiting -> Candidates. (Make sure it has search results)
- Associate this saved search with the talent pool under (Candidates -> Talent Pool -> Edit -> List of Saved searches) Reference KBA : 2721912 - CRM - How to Use Saved Searches to Auto Populate Talent Pools - Recruiting Management
- Wait for the saved search job (Auto populate talent pool) to run in provisioning, and if the number of candidates in the talent pool still stays the same
Cause
There are three possible causes:
- The "Country" field is not filled for the creator/owner of the Talent Pool.
Go to Provisioning -> Monitor Jobs -> Job Name : 'Auto populate talent pool’ click the details of the recent run or a few runs: You should see the below error:
'some pools were skipped because their owners had invalid country values'. This error will occur if there's no Country value in the UDF for the Talent Pool Owner. - The Auto Populate Talent Pool job has inactive executor
Check the job in provisioning to identify the executor. Validate this user is still active in BizX - The Saved Search is including invalid Candidate Profiles in the Search, resulting on having the 'Auto populate talent pool’ job failing.
This issue will occur due to an data inconsistency, and Product Support will have to be engaged to fix it.
Resolution
Cause 1: First, validate if the Talent Pool owner have a valid Country value:
- Make sure that the user who is the owner/creator of the talent pool has a Country defined in the employee/user data file as per the below screenshot.
- Check the Country picklist to make sure the Country is defined as per ISO Country Standards.
- Wait until the next job execution (24-36 hours)
If the issue is still not resolved, submit a ticket to Product Support.
Cause 2: Validate the job executor is active in BizX and reactivate if required
Cause 3: For Product Support only - Check internal memo.
See Also
2668443 - Candidate Talent Pool - members are not found
Keywords
Talent Pool, Saved, search, Members, not found, Auto populate, job, Candidate, search, recruiting, RCM, country, field, UDF, User, File, Data, "Candidate couldn't be derived by ID", "Cannot invoke "com.successfactors.rcm.api.bean.rcmcandidate.ICandidateBean.getUserId()" because "candidate" is null" , KBA , LOD-SF-RCM-CRM , Candidate Relationship Management , Problem
Product
Attachments
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SAP Knowledge Base Article - Public