SAP Knowledge Base Article - Public

3001224 - Revenue is Over-Recognized for Customer Contract Item with Fixed-Price per Period Invoicing (Flat Rate)

Symptom

  • You create a Customer Contract item with the Price per Period Indicator selected.
  • After the End Date of the item you notice that the Revenue Recognition run keeps recognizing the periodic revenue according to the maintained Accrual Method.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. In the Cost and Revenue work center go to the Sales Document Items view. 
  2. Select Customer Contract Items and find item XYZ-XX (XYZ-XX represents the Contract Item ID). The item XYZ-XX is of Revenue Type 5 - Customer Contracts (Fixed Price). 
  3. Open the Contract and go to the Items tab. Find item XYZ-XX.
  4. In the General sub-tab the Price per Period indicator is selected. 
  5. The item has reached its end date, for example 31.03.YYYY  in Accounting period 003.YYYY (YYYY represents the respective (Fiscal) Year). 
  6. Back in the Sales Document Items view go to the Accounting Data tab. Here, a time-based accrual method is assigned, such as Straight-Line - Exact Days or - Even Periods or - Prorate Partial Periods. 
  7. Via the Invoiced Revenues field you notice that the item is fully invoiced (Invoiced amount equals item net value). 
  8. In the Revenues per Period in default Set of Books table you notice that the Revenue Recognition run realized revenue after the contract item's end date, for example in period 004.YYYY (even though the item ends in period 003.YYYY). 
  9. Click on Reports and select Sales Accruals for Customer Contract item. 
  10. You can see that all the Deferred amounts are cleared until period 003.YYYY.
  11. But in the following period, for example 004.2020 the run accrues further revenue.

Cause

For contract items of type Fix Price per Period or flat rate (meaning: when the Price per Period indicator is selected for the contract item) the revenue recognition works slightly different:

The revenue recognition run checks the start and end date of the respective item, as well as the order quantity and net value as usual.

However, if a flat-rate contract item, has not been completed (invoicing finished, end-date reached, fulfillment finished so that Item status becomes Completed) after the initial time period, then the flat rate is applied again for another time period according to the ordered quantity:

Example:

  • Contract Item XYZ-XX
  • End-Date: 31.03.YYYY
  • Ordered Quantity: 30 d (days)

Fulfillment: Item Status: In Process

  • Invoicing: finished
  • End date reached
  • Fulfillment: Not finished

If you execute a run for a period after the end date of the contract item the revenue recognition functionality assumes that the flat-rate duration of the item is to continue. Therefore the ordered quantity/ time period, 30 d (days) is considered again, pushing out the item's end date to 30.04.YYYY.

Resolution

The system works as designed: the ordered quantity of a flat-rate contract item, will be considered again when the revenue recognition run is executed for the item in an accounting period after its end-date, as long as the item is not completed (end-date reached, invoicing finished, fulfillment finished). Once completed all accrued and not invoiced amounts will be cleared again.

See Also

 2967901 Customer Contract Item Still Considered in Revenue Recognition Runs

Keywords

Customer Contract Revenue, Accrued Revenue, over-accrued, over-recognized, flat-rate, price per period invoicing , KBA , SRD-FIN-COR , Cost & Revenue , Problem

Product

SAP Business ByDesign 2008