SAP Knowledge Base Article - Public

3001987 - Feedback Tile created from Continuous Performance Management domain displays Error encountered in executing the query.SAP DBTech JDBC: [339]: invalid number: not a valid number string 'true'

Symptom

  • Dashboard Tile built from Continuous Performance Management  Feedback

An error occurred while calculating data, please try again later or contact your administrator.

txt
Error encountered in getting the data.com.successfactors.analytics.queryengine.exceptions.QueryEngineException: Error encountered in executing the query Error encountered in executing the query.SAP DBTech JDBC: [339]: invalid number: not a valid number string 'true': type_code=29, index=2
id
9
  • The Tile definition has a filter defined for Feedback Visible to Manager  field

    Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HCM Suite
Dashboard Tile

Reproducing the Issue

  1. Login to BizX 
  2. In the Home page you will see the Feedback / [Tile report name] tile.
    Result:  Tile is not showing any data and displays the error: "Error encountered in getting the data.com.successfactors.analytics.queryengine.exceptions.QueryEngineException: Error encountered in executing the query Error encountered in executing the query.SAP DBTech JDBC: [339]: invalid number: not a valid number string 'true': type_code=29, index=2 "
  3. Go to Admin Center>Manage Dashboards>Manage Standard Dashboards and YouCalc Files> Analytics Tile Builder - select the Feedback / [Tile report name] Tile and Edit
  4. Go to the Preview tab. 
    Result:  Same error

Cause

The cause of the issue appears to be the Feedback Visible to Manager filter from the Feedback table.  It seems like field values have changed from True/False to 1/0 perhaps due to the latest changes this 2H 2020 https://launchpad.support.sap.com/#/notes/2975545.
You will notice this detail in the error "Error encountered in executing the query.SAP DBTech JDBC: [339]: invalid number: not a valid number string 'true':

Resolution

Remove the Feedback Visible to Manager filter  and add it back to refresh tile definition

  1.  Edit Tile in Admin Center>Manage Dashboards>Manage Standard Dashboards and YouCalc Files> and go to Filters tab.
  2. Remove or delete  the "Feedback Visible to Manager" filter and Save the changes.
  3. Edit the tile again to add Feedback Visible to Manager ='1' filter back.  Notice that the field values are now 0 and 1 instead of true and false.
  4. Preview the tile Save the changes
  5. View or run the tile in the Home Page or in a Dashboard.  The error should be gone.

Note: You can also edit the tile within Report Center.

Before:

After:

See Also

2975545 - Enhanced Feedback Experience in the Latest Version of Continuous Performance Management - 2H 2020 

Keywords

dashboard tile error, tile error, invalid number, boolean field, Feedback visible, tile filter, CPM tile, feedback tile , KBA , LOD-SF-ANA-DSH , YouCalc Dashboards and Tiles (Dashboards 2.0) , LOD-SF-CPM-FBK , Achievement Feedback, Get Feedback , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors HXM Core 2005

Attachments

Pasted image.png
Pasted image.png