SAP Knowledge Base Article - Public

3002053 - ID Mapping With Wrong System Instance ID After Tenant Refresh

Symptom

After a Tenant Refresh, the System Instance ID for the ID Mapping remains the same as in the Productive Environment.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator.
  2. Click on ID Mapping for Integration.
  3. Select the option Edit ID Mapping for Integration.
  4. Check the System Instance IDs maitained.

Cause

The ID mappings are automatically adjusted by the report Adapt Integration Content for New Tenant. The problem here is that neither the test or actual run finished successfully (you can check in the Application log) and this can only happen if some data has been exchanged before running the report or if you tried to manually adjust the ID mapping beforehand. No task should be performed unless the report Adapt Integration Content has been successfully completed.

Resolution

You can can try deleting all ID mappings created and running the report again. But if you have exchanged messages that creates Business Transaction Document (BTD) references then nothing can be done and you need to request for a new tenant copy. Note: It is mandatory to make sure the report Adapt Integration Content has completed successfully before trying to create any communication arrangement for the new system in the copied tenant.

See Also

For more details about the Adapt Integration Content for New Tenant, please check the following KBA and blogs:

2798209 - C4C - Adapt Integration Content - RFC exception SYSTEM_FAILURE

https://blogs.sap.com/2016/03/16/tenant-refresh-adaptation-support-for-integration/

https://blogs.sap.com/2016/04/06/tenant-refresh-adaptation-support-for-integration-part-ii/

https://blogs.sap.com/2016/04/10/tenant-refresh-adaptation-support-for-integration-part-iii/

Keywords

ID Mapping, Tenant Refresh, System Instance ID. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions