SAP Knowledge Base Article - Public

3002053 - ID Mapping With Wrong System Instance ID After Tenant Refresh

Symptom

After a Tenant Refresh, the System Instance ID for the ID Mapping remains the same as in the Productive Environment.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator.
  2. Click on ID Mapping for Integration.
  3. Select the option Edit ID Mapping for Integration.
  4. Check the System Instance IDs maintained.

Cause

The ID mappings are automatically adjusted by the report Adapt Integration Content for New Tenant. The problem here is that neither the test nor actual run finished successfully (can be checked in the Application log) and this can only happen if some data has been exchanged before running the report No task should be performed unless the report Adapt Integration Content has been successfully completed.

Resolution

It is mandatory to make sure the report Adapt Integration Content has completed successfully before trying to create any communication arrangement for the new system in the copied tenant. If you have already exchanged messages, the report will not run properly since Business Transaction Document (BTD) references are already created in the new system, so the recommended action is to request a new tenant refresh again.

See Also

SAP Blog Post Tenant refresh adaptation support for Integration

 

Keywords

ID Mapping, Tenant Refresh, System Instance ID. Integration Adapt Content, C4C, Cloud for Customer , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions