Symptom
After activating the Machine Learning models on lead and opportunity you see that the score is not getting calculated. It may show the message "Score is currently unavailable." in Insights pane.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Opportunities or Leads view.
- Order the Score column in a descending order.
- Scroll down to the bottom of the column.
Some opportunities or leads are without scoring.
Cause
There are several reasons why some leads or opportunities may not be scored:
- The Leads & Opportunities have a status that is either Converted/Accepted/Declined or Won/Lost. -> Instances with such statuses do not get scored.
- Opportunities and leads closed before the scoring model was activated in your system will not be scored.
- Objects may have the same open and close date. Objects are scored once a day. These objects may not get scored if they are opened and closed before the score run is calculated.
- The score happens once a day. This means, objects that are created on one day, may only receive their scoring the next day.
- In a test/demo landscape tenant daily scoring is restricted to max 2000 records. This is not applicable in productive tenants.
Resolution
This is the correct behaviour.
Keywords
machine learning, model, training, no scoring, missing, sales , KBA , score missing , LOD-CRM-ML , C4C Machine Learning , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , How To
Product
SAP Cloud for Customer core applications 2008