Symptom
The value of the UI validation rule for which the validation is set is true but the validation is not getting triggered.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Quote.
- Create a New Sales Quote.
- Enter the value for the Account.
- Submit the Sales Quote.
- And then Set it as Set as Quoted with pricing.
- Upon Entering Adaptation Mode you can Observe that the Value of the Rule is set to True but Validation is not Triggered.
This is just one example, however the same could be observed in other scenarios, like the Actions button for changing the status of one ticket or sales document.
Cause
- Validations are not Triggered in Backend but they are Triggered in Client immediately after Save Event.
- In the current case the values are set in backend i.e. the status value is changed to 'Set as Quoted with pricing' in backend.
- Values which are set after backend round-trip will always have this reported behavior if they are used in Rule creation.
- Status values are updated correctly only after backend round-trip.
- Therefore values are not up-to-date and validations are not triggered.
Resolution
As KUT validation rules are triggered before backend round-trip and data field value is changed after backend round-trip hence rule condition is not satisfied.
This is the system behavior when dealing with KUT validations and UI rules.
The only way to achieve this requirement is with a SDK custom development (PDI solution).
Keywords
Validations, Triggered, Rules, True, limitation, UI Rule , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , How To