SAP Knowledge Base Article - Public

3004303 - Employee Central (EC) End Date record Sync to Employee Profile (EP) Field Company Exit Date (end-date) is being wiped out During the Incremental Sync Via EC or API Import

Symptom

  • Hris Sync and EP Field Company Exit Date (end-date) Was being wiped out during the Incremental Sync Via EC or API Import
  • Employee Central (EC) End Date record is not syncing to Employee Profile (EP) field Company Exit Date 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

  • SAP SuccessFactors HXM Suite
  • Employee Central - HRIS Sync

Reproducing the Issue

  • Run Daily API upsert or HRIS Sync recurring job
  • Export Employee Export (UDF)
  • Check Terminate user

Result:

  • Company Exit Date: blank

Configure the sync-mapping between EC "Termination Date" and Platform "Company Exit Date"

  1. Navigate to "employmentInfo" element under Employee Central > HRIS Elements
  2. Select "Details" to the right of the field "end-date"
  3. Scroll down the Details pop-up to the "HRIS Sync Mapping" section and select the Company Exit Date field
  4. Click "Done" then click "Save" at the bottom of the employmentInfo element field list

Please refer article 2617614 - Employee Profile: How to Configure companyExitDate Field under Manage Business Configuration

Cause

This a bug in the code where users_sys_exitdate was not part of query (user bean) and therefore set to null during the recurring incremental sync, provided there are no updates in the Employment Info record of a particular user

HrisSync uses functionalUserQueryDao.findUsersByIdInBatch() to get userBeans. This query doesn't set the existing users_sys_exitdate to the userBean. When HrisSync save this userBean back to user table, it will override the existing value.

Resolution

This is a known issue. The engineering team will deploy a fix in B21105 release.

  • No date has been confirmed at this time
  • Keep tracking release note B21105: PLA-17311

Workaround:

Run Full Hris Sync

As a customer, you don't have access to Provisioning. To complete tasks in Provisioning, contact your implementation partner. If you're no longer working with an implementation partner, contact SAP Cloud Support.

Employee Central Support Engineer Team Action:

  1. Please refer to Internal Meno

Also

See Also

  • 2617614 - Employee Profile: How to Configure companyExitDate Field under Manage Business Configuration
  • 2618726 - Syncing the country/region of Company between Employee Central and the SuccessFactors Platform
  • 2614665 - Syncing the Termination Date between Employee Central and the SuccessFactors Platform
  • 2657326 - Data Retention Time Management: Person and Employment Purge Object FAQ

Keywords

INC0148755, PLA-17311, B21105, HRIS Sync, company exit date, SRSD-83740, employee Profile, employee central , KBA , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , Problem

Product

SAP SuccessFactors HXM Core 2005