Symptom
None of the fields are visible for some candidates when they are trying to access their candidate profiles. But some candidates can access those fields with their information.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Log in to Instance
- Go to Careers >> My Candidate Profile
- None of the fields are visible.
Cause
Country code of the candidate is in incorrect format. It should be a 2 letter code of the country and not as a whole word defined in the candidate profile.
Resolution
Change the country code field on the Candidate profile and make sure that it is in a 2 letter code format and not as a whole word of the country.
Any changes to address field in Employee Profile will sync the country field value to candidate profile if the field is sm-mapped and the COUNTRY_CODE should be updated with 2 letter code.
See Also
Keywords
Candidate, profile, empty, values, missing, country, sm-mapped, employee, profile , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem
Product
Attachments
image.png |