Symptom
We have an event that triggers in job info when the business unit is changed. This doesn't trigger if the change is made in the position and synced to job information via the sync logic
Environment
Employee Central - Intelligent Services
Reproducing the Issue
1. Change the business unit via the position org chart
2. Observe field changed in Job Info
3. No event triggered in Intelligent Services
Cause
For an event to be triggered, the element must be directly edited and saved.
Resolution
During the position to job info sync, job info is not directly accessed to make the change, hence the rule doesn't trigger.
At this time there is no workaround and if the events are to be triggered, job info must be edited directly.
Keywords
Intelligent Services Event, Intelligent Services Position, Position to Job Info sync , KBA , LOD-SF-EC-ITS , Intelligent Services (EC Components Only) , LOD-SF-EC-POS , Position Management , Problem