SAP Knowledge Base Article - Public

3005392 - "ID Mapping for External Value 123 of Organisational Centre ID Missing" Error Raised when Replicating Leads from Marketing Cloud to C4C

Symptom

You are replicating Leads from SAP Marketing Cloud to SAP Cloud for Customer, however the message is failing with the "ID mapping for external value 123 of Organisational Centre ID missing" error in C4C Web Service Message Monitoring.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to Web Service Message Monitoring under Administrator Workcenter.
  2. Search for the Service Interface - LeanLeadReplicationInitiatedByExternalIn.
  3. You will be able to see the error.

Cause

The ID Mapping for the Sales Organization ID is not correctly mapped.

<SalesAndServiceBusinessArea>
<SalesOrganisationID>123</SalesOrganisationID>
</SalesAndServiceBusinessArea>

Resolution

In order to fix the issue, you need to map the ID (123) under the "CRM Organizations and Units" instead of ERP Sales Organizations.

Keywords

KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer add-ins all versions