Symptom
You are replicating Leads from SAP Marketing Cloud to SAP Cloud for Customer, however the message is failing with the "ID mapping for external value 123 of Organisational Centre ID missing" error in C4C Web Service Message Monitoring.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Web Service Message Monitoring under Administrator Workcenter.
- Search for the Service Interface - LeanLeadReplicationInitiatedByExternalIn.
- You will be able to see the error.
Cause
The ID Mapping for the Sales Organization ID is not correctly mapped.
<SalesAndServiceBusinessArea>
<SalesOrganisationID>123</SalesOrganisationID>
</SalesAndServiceBusinessArea>
Resolution
In order to fix the issue, you need to map the ID (123) under the "CRM Organizations and Units" instead of ERP Sales Organizations.
Keywords
KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem