SAP Knowledge Base Article - Public

3005834 - OnChange Business Rule not Working for Read-Only Fields - Recruiting Management

Symptom

A Business Rule set as OnChange is not changing the value of a read-only field.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Create a Business Rule;
  2. Set the rule as OnChange under Manage Rules in Recruiting;
  3. Go to the RCM form you defined the rule (e.g., Job Requisition);
  4. Trigger the rule;
  5. Notice that the changes were not applied or only applied to writable fields;

Cause

This is an expected behavior based on the structure of Business Rules in Recruiting. Please refer to the Resolution section.

Resolution

On the current design, if an OnChange Business Rule is triggered by the user/operator, the same user/operator must have write permission to the relevant field that the rule will be changing. If the user/operator does not have permission, the rule not will trigger the change upon the field.

This information is addressed on the following sections of the Implementation Guide:

"The onSave trigger can default or update values into a read-only field. However, if the user doesn’t have edit permission, you can’t use the onChange trigger to default values into a read-only field in the requisition."

As a workaround, you can define the same rule as OnSave or define write permissions to the user/operation in question.

See Also

2987208 - "errorMessage=f.setSelectedValue is not a function" on Job Application page - Recruiting Management

Keywords

changes, change, saving, saved, not, object, not, working, properly, rule, rules , KBA , LOD-SF-RCM-RUL , Recruiting Rule Issues with MDF Platform , Problem

Product

SAP SuccessFactors Recruiting all versions