Symptom
- Error when trying export activities to specific process
- Export to excel not working
- Export to excel activity return an error
- Could export for other processes
- An embedded page at onboarding4.successfactors.com says Error: {"ResponseStatus": {"ErrorCode":"InvalidOperationException", "Message":"Sequence contains no matching element"}}
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Login SuccessFactors HXM
- Go to Onboarding > Work Queue - New Version > e.g. COVID-19 Physical Inspection Process
- Tick "Physical Inspection"
- Task checkbox
- Then, click "Export"
- Pop appears, "File creation can take a couple of minutes. Download?"
- Then, select OK
Error: {"ResponseStatus":{"ErrorCode":"InvalidOperationException","Message":"Sequence contains no matching element"}}
Cause
Due to no index fields configured in the process.
Resolution
Please contact implementation Partner to configure index fields. Check this KBA 2780773 for more details of the steps.
See Also
Keywords
Index, Fields, Export, Excel, Working, Error, Exporting, Process, Activities, InvalidOperationException, ErrorCode, Message, Sequence, Contains, No, Matching, Element, Receiving, Specific, Onboarding, Onb, Obd , KBA , LOD-SF-OBD-ADM , Admin Tools, Settings, Permissions , LOD-SF-OBD-NHA , New Hire Activity , Problem
Product
Attachments
Pasted image.png |