SAP Knowledge Base Article - Public

3007539 - Continuous Performance Management Reports, Tiles, and Dashboards using "Feedback Visible to Manager" as a filter field have stopped working

Symptom

  • A report for Continuous Performance Management domain is configured to filter results using the field "Feedback Visible to Manager" has stopped working
  • When opening a Continuous Performance Management tile or dashboard, an error is generated
    • An error occurred while calculating data, please try again later or contact your administrator
    • invalid number: not a valid number string 'true'
    • invalid number: not a valid number string 'false'

Environment

SAP SuccessFactors Continuous Performance Management

Cause

In the 2H 2020 release, the field "Feedback Visible to Manager" was changed from Boolean type to integer type, therefore in reports the values will be "1" or "0" instead of "true" or "false". Filters using the "Feedback Visible to Manager" that were created prior to the 2H 2020 release may still have the "true" or "false" value selected.

Resolution

  • In Report Center, find the report/tile in question, click on the "..." in the "Actions" column and select "Edit"
  • Select the Filters pill, if there are multiple filter groups find the group using "Feedback Visible to Manager" and click " Refine Criteria"
  • Delete the Feedback Visible to Manager filter from the Selected Filter column
  • Add the Feedback Visible to Manager filed back by clicking on the checkbox and selecting the criteria (0 or 1)
  • Click "Done" and save the report/tile

Keywords

CPM, SFSF, SF, Feed back, success factors , KBA , LOD-SF-CPM-REP , Reporting & Analytics, Data Imports & Exports , Problem

Product

SAP SuccessFactors Performance & Goals all versions