Symptom
You are getting the below error when you click on Check Connection in the Communication Arrangement of Custom Webservice.
"
Error accessing service; Service Ping ERROR: Error when calling SOAP Runtime functions: SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_CONNECTION_BROKEN") ()
Ping failed
Checking connection failed
"
Environment
SAP Business ByDesign
Reproducing the Issue
- Login to the frontend UI.
- Navigate to the Administrator work center.
- Select Communication Arrangement subview.
- Open the Communication Arrangement that you have created from SDK.
- Navigate to the Technical Data.
- Click on the button Edit Advanced Settings.
- Select the service and click on the button Check Connection.
- Error Appears.
Cause
This is this is Technical limitation cause it does not depend on ByDesign but also the external system with which communication is arranged
Resolution
Please use 'Postman' tool to check the connection or simply create documents and if documents are created successfully that means that connection is set up successfully.
Download Postman Tool from Google and then as highlighted in yellow in below screen enter the details
Click on '+'
In the new tab 'Enter request URL'
Go to 'Authorization' tab
Choose 'Basic auth'
Enter technical user ID and pass word
Click on 'send'
Then you will get what is seen in below screen
If the status is showing points from 200 to 300 that means there is no connection problem
See Also
2660652 - Error While Checking Connection in the Custom Web Service Communication Arrangement
Keywords
KBA , AP-RC-CEC-B2B , ByD On-Demand Cloud-Process Integration B2B , AP-SIP , Supplier Invoice Processing , AP-POP-PO , Purchase Order , AP-RC-BDS-WS , ByDesign Studio Web Services , Problem