SAP Knowledge Base Article - Public

3010056 - Entry 'Service Order SO' is missing in App Create Maintenance Plan

Symptom

The Entry for 'Service Order SO' is missing from the App Create Maintenance Plan when following the Test Script for Scope item 4X5

Environment

  • SAP S/4HANA Cloud Public Edition
  • Services

Reproducing the Issue

  1. Open Create Maintenance Plan app
  2. The Dropdown for the field 'Maintenance Plan For' is missing 'Service Order SO'  ( Only shows Maintenance Order )

Cause

The Role  SAP_BR_SERVICE_PLANNER or Business Catalog SAP_SERV_BC_RECUR_MGR_PC  is not assigned

Resolution

Assign the Role SAP_BR_SERVICE_PLANNER to the User in the App Maintain Business User or a Role with the  Business Catalog SAP_SERV_BC_RECUR_MGR_PC

If the Role SAP_BR_SERVICE_PLANNER, or a Role with Business Catalog SAP_SERV_BC_RECUR_MGR_PC  is assigned , please ensure write restriction is not set as "No Access" as this can prevent the entry  'Service Order SO' from appearing in the App Create Maintenance Plan

See Also

If the Scope item 4X5 is active and the Role  SAP_BR_SERVICE_PLANNER  is missing from the app Maintain Business Role  , please follow the steps follow :

  1. Open App Maintain Business Role
  2. Create From Template
  3. Press F4 on Template Field
  4. Search for Template SAP_BR_SERVICE_PLANNER
  5. Select Entry for SAP_BR_SERVICE_PLANNER
  6. Press Ok ( Create new Role for SAP_BR_SERVICE_PLANNER )

Keywords

Service Planner - Recurring Service. , KBA , CRM-S4-SRV-MNO , S4CRM: Service with Advanced Execution , PM-PRM-MP , Maintenance Plans , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions