SAP Knowledge Base Article - Public

3011095 - SAP SuccessFactors Operations Best Practice: Synthetic User Monitoring

Symptom

You operate SAP SuccessFactors and want to know about SAP Best Practice Cloud Operations. You want to establish efficient and effective User Experience Monitoring of this cloud solution.

Environment

 SAP SuccessFactors (SaaS)

Reproducing the Issue

You need to design, adjust, or otherwise establish User Experience Monitoring for your SAP SuccessFactors environment.

Cause

 SAP Best Practice Cloud Operations are not yet followed.

Resolution

User Monitoring allows to monitor the performance and availability of SAP SuccessFactors from an end-user point-of-view.

Goal

Ensure the technical availability and reasonable performance of important business scenarios from an end-user point-of-view. Establish an automatic, always-on monitoring solution for critical business scenarios.

Background

User Experience Monitoring allows the measurement of synthetic end-user requests across systems and technology.

User Experience Monitoring, also known as Synthetic User Monitoring, provides a simulation of end-user behavior based on selected scenarios, which are scripted and deployed at robots located in the customer landscape. These recorded scripts are replayed by the robots on regular basis to measure availability and performance from the different locations within a customer landscape. User Monitoring is relevant for cloud centric as well as for hybrid customers. It addresses mainly IT users, however, also LOB (line of business) users may be interested in other aspects e.g. end user performance.

User Experience Monitoring

Synthetic User Experience monitoring can be enabled in SAP Solution Manager and SAP Focused Run for evaluating and reporting the availability and performance of various SAP SuccessFactors scenarios from an end user perspective, see data collection (1) and (2). This functionality in SAP Solution Manager and SAP Focused Run can be used to be alerted of unexpected downtimes and performance degradation and to troubleshoot unexpected situations with the integrated E2E Trace Analysis of E2E Diagnostics, see (3).

User Experience Monitoring

For details about User Experience Monitoring in SAP Solution Manager, please refer to SAP Help Portal.
For details about Synthetic User Monitoring in SAP Focused Run, please refer to SAP Help Portal.
For details about configuration of User Experience and Synthetic User Monitoring, refer to SAP Expert Portal for User Experience Monitoring.

What to monitor and alert, report, analyze (RCA), visualize, meter

When deciding which scenario to record for User Experience Monitoring/Synthetic User Monitoring it is important to keep the following principles in mind:

  • The scenario shouldn’t change or create any business data in the involved systems,
  • The scenario should be a typical task that is performed by end-users,
  • The scenario should be kept simple.

The reasons for above recommendations are the following:

1. The script must not change the data of real business users in the system, like user master data, pay data or absence data. The only way to prevent this would be to change the user data of a dummy user, for example let them create an absence or change their address. To make this a feasible scenario you must reverse the change before ending the scenario. Otherwise, the second time the user data will not be changed anymore, and if the user keeps creating absences every ten minutes it will run out of quota very soon.

2. The scenario performed by the robot should reflect what end-users typically use the system/the service for. An option to find out what this is could be to ask users or to observe their system interaction. It does not make sense to script scenarios that perform end-user tasks that are only executed rarely and sporadically.

3. The scenario and script should be as simple as possible. The more complex the recorded scenario is, the more error prone is it. This can lead to false alerts. Another point here is the editing and the maintenance of the script itself. A very complex script can be hard to edit to run from a robot afterwards. A small change in any part of the solution, can require big changes or even a complete rerecording of the script. A simple straight forward script which only requires minimal editing after the recording, keeps the maintenance and post-editing lower.

For SAP SuccessFactors, a basic scenario could be:

Step 1: The end-user logs on the SAP SuccessFactors,

Step 2: The end-user searched for another person or for a course,

Step 3: The end-user goes back to the Home page,

Step 4: the end-user logs off.

For SAP SuccessFactors and SAP Enterprise Resource Planning (ERP, S/4HANA,...) hybrid scenarios, this type of monmotoring is also applicable. E.g. SAP SuccessFactors Employee Central (SFSF EC) to work (via SAP middleware) with SAP Human Capital Management (HCM) or SAP SuccessFactors Employee Central (SFSF EC) to work directly with SuccessFactors Employee Central Payroll (ECP).

See Also

Knowledge base Articles:

Keywords

OCC; Operations Control Center; CCOE; Customer Center of Expertise; E2EHO; SFSF; SuccessFactors; Cloud Operations; Cloud Monitoring; User Experience Monitoring; Synthetic User Monitoring , KBA , XX-SER-MCC , Mission Control Center - Knowledge Management , How To

Product

SAP SuccessFactors HCM Core all versions