SAP Knowledge Base Article - Public

3011108 - SAP SuccessFactors Operations Best Practice: Integration Monitoring

Symptom

You operate SAP SuccessFactors and want to know about SAP Best Practice Cloud Operations. You want to establish efficient and effective Integration Monitoring of this cloud solution.

Environment

SAP SuccessFactors (SaaS)

Reproducing the Issue

You need to design, adjust, or otherwise establish Integration Monitoring for your SAP SuccessFactors environment.

Cause

SAP Best Practice Cloud Operations are not yet followed.

Resolution

Integration Monitoring provides real-time monitoring of interfaces, calls and/or message flows, i.e. the handling of single message flows processed by SAP Cloud Platform Integration as well as peer-to-peer interface usage via REST Service or SOAP Service calls.

Goal

Ensure the healthiness of interfaces and interface steps of business services and detect anomalies of interface executions.

Background

Integration Monitoring helps to manage complex and integrated landscapes with millions of interfaces, calls and/or message flows. It covers the handling of single message flows processed by SAP Cloud Platform Integration, as well as peer-to-peer interface technologies as REST Service or Web Service calls on single execution level. In addition, the handling of integration exceptions related to SAP-based cloud products, such as SAP Cloud for Customers, SAP Cloud Platform, SAP SuccessFactors, and SAP Ariba is necessary. Out-of-the-box visibility in SAP Cloud Platform Integration, SAP Process Integration and other orchestration platforms including related integration content is provided.

Integration Monitoring is evolving in the direction of end-to-end message flow monitoring. With the help of the SAP Passport we enable the horizontal correlation of integration artifacts to end-to-end message flows. This helps you to understand the root cause of a certain integration related issue by providing transparency following the complete flow. Integration Monitoring is relevant for cloud centric as well as for hybrid customers. It addresses the needs of LOB users as well as IT users (common language).

1 Integration with SAP SuccessFactors Cloud

SAP SuccessFactors Cloud Integrations can be built using the SuccessFactors Integration Center, SAP Cloud Platform Integration, SAP Process Integration/Process Orchestration, SAP One Master Data Integration Service, or other 3rd party middleware.

No matter which integration is used, it falls to the customer to monitor the integration between SAP SuccessFactors and other applications. For cloud only customers the following monitoring tools available in SAP SuccessFactors can be used for this purpose.

For customers integrating SAP SuccessFactors with on-premise applications like SAP HCM the monitoring can be set up using SAP Solution Manager. This approach is described in the section ‘Integration Monitoring Tools in SAP Solution Manager.

1.1 Integration Monitoring Tools in SuccessFactors

1.1.1 OData Audit Log

The HXM Suite OData API is SuccessFactors Web Services API based on OData protocol intended to enable access to data in the SuccessFactors system. OData Audit Log can be used to monitor API calls to SuccessFactors for standard and 3rd party integrations, and can be used to debug API issues. To access the OData Audit Log, go to the Admin Center > Odata Audit Log. The audit log will show the last 10,000 API calls to the system. You can use the session ID from the middleware to find a specific API call. For each call, you can view the SOAP or HTTP payload details. To view the payload information, in the log table select the button under the HTTP or REST columns. You can view the response and request for both failed and successful API calls. You can also download data from individual calls. See the following guide: SuccessFactors HCM Suite OData API: Developer Guide.

1.1.2 SFAPI Audit Log

SFAPI Audit Log can be used to monitor API calls to SuccessFactors Employee Central, and can be used to debug API issues. SFAPI is used for the Employee Central Compound Employee API (CE API) for extracting employee data and organizational assignments out of Employee Central. To access the SFAPI Audit Log, go to the Admin Center > SFAPI Audit Log. The audit log will show the last 10,000 API calls to the system. You can use the session ID from the middleware to find a specific API call. For each call, you can view the SOAP or HTTP payload details of the data sent. You can view the response and request for both failed and successful API calls. You can also download data from individual calls. See the following guide: SuccessFactors HCM Suite SFAPI: Developer Guide.

1.1.3. CPI Monitoring (for Middleware based integration)

For all Cloud Platform Integrations, including custom or standard iFlows, all monitoring would be performed from the SAP Cloud Platform.

1.2 Integration Monitoring Tools in SAP Solution Manager

Integration Monitoring in SAP Solution Manager offers a whole suite of tools to allow for end-to-end monitoring of an SAP SuccessFactors integration with an on-premise SAP HCM system.

These applications are:

  • Exception Management: Used to collect exceptions occurring in SAP Cloud Services like SAP SuccessFactors and SAP on-premise systems in the global exception store in SAP Solution Manager
  • Interface and Connection Monitoring: Used to monitor point-to-point interfaces between SAP systems, SAP public cloud services and non-SAP systems. Interface and Connection Monitoring is also used to monitor the collected exceptions in Exception Management and create alerts based on the exceptions in the global exception store
  • PI Monitoring: Used to monitor the components, channels and messages in an SAP Process Integration or SAP Process Orchestration domain. SAP PI/PO can be used for the integration of SAP public cloud services and SAP on-premise systems.

All application mentioned above integrate with the SAP Solution Manager Unified Alert Inbox and Notification Management. Using SAP Solution Manager to monitor the integrations in your SAP SuccessFactors hybrid solution allows for automatic, pro-active monitoring with one central monitoring system. This approach is preferable to the use of multiple, manual monitoring applications or transactions.

When it comes to the integration of SAP SuccessFactors with SAP in-premise applications like SAP HR or SAP ERP there are different technologies that can be used for the integration.

The following graphic shows some possible integrations and the relevant monitoring key figures. Customers can use a combination of all three solutions, e.g. FTP replication for Talent Management and SAP PI pass-through with SAP CPI for Employee Central master data replication.

Integration Monitoring

Figure 1: Selected Integration Options for SAP SuccessFactors

To identify which monitoring objects/key figures need to be implemented, the customer needs to know two things:

  1. Which functionalities in SAP SuccessFactors are in use in your organization?
  2. How does each of the functionalities integrate with other components?

The integration solution determines which interfaces need to be monitored technically, e.g. it would not make sense to monitor FTP files, if the integration is done using SAP Cloud Platform Integration and SAP PI. The functionalities used determine which exception related key figures are relevant, e.g. a customer that is not using Talent Management will have little success monitoring Talent Management KPIs. For Integration Monitoring the relevant key figures are monitored using the application "Interface and Connection Monitoring" in SAP Solution Manager.

The key figures are part of so-called Interface Channels. Each interface Channel has a type, i.e. RFC, Web Service, Cloud etc. The setup of the different interface channel types differs by type. Please refer to the documentation provided in the SAP Solution Manager Expert Portal for the technical setup of the monitoring for each channel type. For general information about Integration Monitoring, refer to SAP Help Portal.

The following table contains key figures relevant for different SAP SuccessFactors integrations, the description of the collected key figure and for which functionalities / integrations they are relevant. The columns 'Interface Channel Type' indicates in which interface channel the key figure can be found. Please follow the documentation provided above for the detailed setup of each channel type. Choose the key figures based on your integration solution and the functions used in SAP SuccessFactors.

Interface Channel Type: Template

Key Figure

Description

Relevance

Cloud: Cloud (Success Factors)

Number of exceptions (Data Replication Monitor)

 

Single exceptions (Data Replication Monitor)

 

This key figure collects exceptions that are recorded in the SAP SuccessFactors Data Replication Monitor.

Relevant for data replications between SAP HCM and SAP ECP and SAP SuccessFactors for employee master and organizational data, time off and time sheet data.

Cloud: Cloud (Success Factors)

Number of exceptions (Integration)

 

Single exceptions (Integration)

This key figure collects exceptions that are recorded in the SAP SuccessFactors Execution Center for middleware integrations via the OData API.

Relevant for integration that are defined in the SAP SuccessFactors Execution Manager > Middleware Integrations and are of process type INTEGRATION, HCI_INTEGRATION and PI_INTEGRATION

Cloud: Cloud (Success Factors)

Number of exceptions (Scheduled Jobs)

 

Single exceptions (Scheduled Jobs)

 

This key figure collects exceptions that are recorded in the SAP SuccessFactors Execution Manager in the job log for jobs executed in SAP SuccessFactors.

Relevant for jobs that are executed in the SAP SuccessFactors Execution Manager > Scheduled Job and are of process type SCHEDULED_JOB.

Cloud: Cloud (Success Factors)

Number of exceptions (Simple Integration)

 

Single exceptions (Simple Integration)

This key figure collects exceptions that are recorded in the SAP SuccessFactors Execution Manager for direct integrations executed via the Integration Center.

Relevant for integration that are defined and monitored in the SAP SuccessFactors Execution Manager > Integration Center and are of process type SIMPLE_INTEGRATION.

Cloud: Cloud (Success Factors)

Number of exceptions (Talent Management - XXX)

 

Single exceptions (Talent Management - XXX)

 

These key figures collect exceptions for the Talent Management application in different areas like Compensation, Onboarding, Employee Data, Recruiting and Variable Pay.

The exceptions are collected from the HCM Exception Log in the SAP HCM on-premise system, not from SAP SuccessFactors.

Only relevant of you are using the Talent Management application together with the SFIHCM integration add-on in your on-premise system.

Web Service: Web Service ABAP (STAD)

Web Service performance and throughput metrics

Use this interface channel to monitor the web service endpoints in the SAP HCM system. You need to set up separate channels for incoming web service calls and outgoing web service proxies.

Relevant if web service messages are used to communicate the SAP Cloud Platform integration or SAP SuccessFactors.

To verify which web services are relevant and used in your SAP HCM system please check transaction SRT_LOG or SRT_MONI.

Web Service: Web Service ABAP (STAD)

Number of AppLog Errors (WS)

Monitor Application Log entries relevant for SAP SuccessFactors integrations in the SAP HCM system.

There is no dedicated channel type for Application Log messages, so this metric serves as the monitoring tool for those. For SAP SuccessFactors the following Application Log messages can be relevant:

ECPAO_IN

PAOC_SFI_PA

PAOC_SFI_OM

ECPAO

RFC: RFC

RFC availability, throughput and performance metrics

Use this interface channel to monitor the RFC destinations in the SAP HCM system (SM59) that are used for the SAP SuccessFactors integration.

Relevant as RFCs of type HTTP (G) are usually used to communicate with SAP CPI or SAP SuccessFactors

RFC: RFC

Number of AppLog Errors (RFC)

Monitor Application Log entries relevant for SAP SuccessFactors integrations in the SAP HCM system.

There is no dedicated channel type for Application Log messages, so this metric serves as the monitoring tool for those. For SAP SuccessFactors the following Application Log messages can be relevant:

ECPAO_IN

PAOC_SFI_PA

PAOC_SFI_OM

ECPAO

IDoc: IDoc (Real-time Monitoring)

 

Current number of erroneous IDocs (Real-time) (Delta)

Monitor IDoc errors for outgoing IDocs in the SAP HCM system

IDocs are usually used or the replication of Cost Centers or quotas via SAP PI or for file-based replication.

IDoc: IDoc (Real-time Monitoring)

Current number of erroneous IDocs (Real-time) (Total)

Monitor IDoc backlog for outgoing IDocs in the SAP HCM system

IDocs are usually used or the replication of Cost Centers or quotas via SAP PI or for file-based replication.

 

File: File (Remote)

File age

Monitors the age of a file on OS level on a remote FTP host

This metric can be used to monitor if a file is not picked up in a certain timeframe, e.g. because it is damaged, or the integration solution is not functional.

File: File (Remote)

File exists / File size

Monitors the existence and the size of a file on OS level on a remote FTP host

This metrics are only relevant if you have a strictly scheduled file transfer. If the pick-up of the files is random or happens within a very short time, this metric will not be useful

File: File (Diagnostic Agent)

Age of File

Monitors the age of a file on OS level on an SAP host with a Diagnostics agent, e.g. the SAP HCM system

This metric can be used to monitor if a file is not picked up in a certain timeframe, e.g. because it is damaged, or the integration solution is not functional.

File: File (Diagnostic Agent)

Number of Files available / Size of File

Monitors the age of a file on OS level on an SAP host with a Diagnostics agent, e.g. the SAP HCM system

This metrics are only relevant if you have a strictly scheduled file transfer. If the pick-up of the files is random or happens within a very short time, this metric will not be useful

Process Integration: Process Integration (PI)

Metrics for PI Message Status monitoring

Monitors message in error, cancelled, successful, or intermediate status based on the messages in the SAP PI system message monitor (PI Monitoring setup is a prerequisite)

Relevant if you use SAP PI to integrate with SAP SuccessFactors.

Process Integration: Process Integration (PI)

Metrics for PI Channel Status monitoring

Monitors channels in error status. (PI Monitoring setup is a prerequisite)

Relevant if you use SAP PI to integrate with SAP SuccessFactors

Process Integration: Process Integration (PI – ABAP only)

Metrics for PI Message Status monitoring

Monitors messages in the SAP ABAP systems ABAP proxy.

Relevant if you use SAP PI to integrate with SAP SuccessFactors. To find the messages being send via the ABAP proxy please use transaction SXMB_MONI in the SAP ABAP system.

 

Cloud: Cloud (SAP Cloud Platform Integration)

Number of erroneous iFlows in SAP CPI (Delta)

 

Number of erroneous iFlows in SAP CPI (last 24h)

Monitors for IFlows in Error state directly in SAP CPI

Relevant if you use SAP CPI to integrate with SAP SuccessFactors

 

Cloud: Cloud (SAP Cloud Platform Integration)

Number of erroneous iFlows in SAP CPI (Delta from ExcMgmt)

 

Number of erroneous iFlows in SAP CPI (last 24h from ExcMgmt)

Monitors for IFlows exceptions collected by Exception Management in SAP Solution Manager (you must activate Exception Management before being able to successfully use this metric)

Relevant if you use SAP CPI to integrate with SAP SuccessFactors

 

Cloud: Cloud (SAP Cloud Platform Integration)

Average Response Time of iFlows in SAP CPI

 

Average Response Time of iFlows in SAP CPI per iFlow

Monitors the response time for IFlows directly in SAP CPI

Relevant if you use SAP CPI to integrate with SAP SuccessFactors

 

Cloud: Cloud (SAP Cloud Platform Integration)

Number of iFlow executions in SAP CPI

Monitors the number of executions per IFlows directly in SAP CPI

Relevant if you use SAP CPI to integrate with SAP SuccessFactors

 

While there are specific web services, IDoc types and Application Log entries used for the integration with SAP SuccessFactors, the specifics depend on the technical integration type and the integrated data at the customer. Different integration types and data will write different kind of log messages and use different web service endpoints.

To find out which filter values must be used during the setup if the key figures above, you can either check the corresponding transactions in the managed SAP HCM system:

  • IDocs: WE05
  • PI messages via ABAP proxy: SXMB_MONI
  • Web Service messages: SRT_MONI
  • Web Service exceptions: SRT_LOG
  • Application Log messages: SLG1
  • RFC destinations: SM59 (under subtree HTTP Connections to External Server (G))

Or you can refer to the Integration Scenario Finder to find the documents that describe your integration.

See Also

Knowledge base Articles:

Keywords

OCC; Operations Control Center; CCOE; Customer Center of Expertise; E2EHO; SFSF; SuccessFactors; Cloud Operations; Cloud Monitoring; Integration Monitoring; Interface Monitoring; Exception Management , KBA , XX-SER-MCC , Mission Control Center - Knowledge Management , How To

Product

SAP SuccessFactors HCM Suite all versions