SAP Knowledge Base Article - Public

3011110 - SAP SuccessFactors Operations Best Practice: Integration with 3rd Party Tools and Systems

Symptom

You operate SAP SuccessFactors and want to know about SAP Best Practice Cloud Operations. You want to establish efficient and effective Integration with 3rd Party Tools and Systems of this cloud solution.

Environment

SAP SuccessFactors (SaaS)

Reproducing the Issue

You need to design, adjust, or otherwise establish Integration with 3rd Party tools and systems for your SAP SuccessFactors environment.

Cause

SAP Best Practice Cloud Operations are not yet followed.

Resolution

The SuccessFactors Integration Center is used to build, run, schedule and monitor simple flat file based outbound integrations with 3rd party systems.

Integration Center Execution Manager Dashboard

The status of the Integration Center background job is visualized in the Execution Manager Dashboard. This dashboard is accessed via Admin Tools > Integration Center > Monitor Integrations. Customers can monitor the status of executed integrations and integrations in progress, and view all of the integrations and their statuses compiled in a chart. Customers can also view useful error/log messages in the Execution Manager. In the Next Gen Admin Center, an Integration Dashboard is available, which displays a miniature version of the integration chart provided by the Integration Center Monitor. A hyperlink in this dashboard allows to navigate to Execution Manager directly. In addition, the Scheduled Jobs Dashboard shows all scheduled integrations and allows a navigation directly into the Scheduled Job menu of the Integration Center Execution Manager.

Integration Center

Find further details in the following Knowledge Base Articles (KBAs):

Intelligent Services Center

Intelligent Services Center (ISC) simplifies the user experience for employees, managers, and business partners by integrating into a single experience the individual transactions in a multi step HR process that cross the traditional boundaries of HXM applications and organizational departments. Intelligent Services links with external systems that allow seamless integration with third-party applications.

Customers can also use intelligent services events to trigger processes in 3rd party applications. In such a process model, any SAP SuccessFactors product can raise and publish an event. Any SAP SuccessFactors solution or third-party application can subscribe to any published event. Publishers can send out external notifications That can be received by subscribers. In many cases, we have seen customers using Cloud Platform Integration iFlows to listen to Success Factors events and trigger processes in 3rd party applications.

The intelligent Services Center enables customers to set up and monitor intelligent Services. As an HR analyst or an IT or HR administrator, a customer user can use it to model your business processes for intelligent Services. ISC can be launched from Admin Center -> Intelligent Services Center Using ISC can configure, customize, and monitor Intelligent Services events that include:

  • Publisher details
  • Subscriber actions and notifications
  • External Event Connector
  • Integrations created through the Integration Center
  • Event monitoring Customers can access Event Monitoring for your event to find the Event Monitoring Details view, which should be near the Event Monitoring chart. The Event Monitoring Details view contain three basic columns:
    • Date
    • Time
    • Initiator

The date and time colums contain the date and time when the event ran. The Initiator column contain individual that initiated the event. Customers can also view your payload details for any external third-party application that subscribe to Intelligent Services using Event Connector option. For detailed information on the ISC and Event Monitor, refer to the help documents below:

ISC Event Monitor

Integration with 3rd Party Tools and Systems

SAP Solution Manager or SAP Focused Run can be connected to SuccessFactors and used as the monitoring system for SuccessFactors.

SAP Focused Run

As soon as monitoring and alerting data is collected in Focused Run, alerts can be forwarded to third-party ITSM systems either automatically or manually.

Focused Run Integration

Outbound from Focused Run to Third-Party System:

  1. BADI Implementation: before an alert can be forwarded to a Third-Party system, the BADI BADI_ACC_REACTION_EXT has to be implemented and set to active. The Focued Run Guide AEM - Third-party Alert Consumer Connector BAdI implementation contains the detailed information about the Focused Run alerts and how to implement this BADI. Inside this BADI one has to implement ABAP codes which call the web service provided by the customer to create an event or case on the Third-Party system. Note that each customer may have their own implementation of inbound web service even though they use the same product (e.g. ServiceNow, Remedy, etc.).
  2. After the BADI is implemented, it can be found in the Outbound Integration of Focused Run.
    • Automatic Option: on the global or template level, the alert can be configured to an Outbound Integration Variant which points to the BADI implementation. Any alert configured to this Outbound Integration Variant will be forwarded to the corresponding Third-Party system.
    • Manual Option: alerts can also be inactive to any Outbound Connection Variant. In this case, users can pick this alert -> Actions -> Trigger Alert Reaction -> Select the BADI implementation of the Third-Party system as shown in the screen shot.

Alert Reaction BAdI

Inbound from Third-Party system to Focused Run Alert:

Once a Focused Run alert is sent and resolved in the Third-Party system, the Third-Party sustem can send a confirmation to Focused Run to confirm this alert. The web service is an OData service call with the URL like the following:

https://(server)/sap/opu/odata/sap/ACC/ConfirmAlertType?ContextId=%27AE8B74E0DF1ED789 C7B2AF56BFBE65%27&AlertTypeId=%27FA16E799B31EE789A01A532CB80581%27&Comment= %27Test%27&ConfirmTimestamp=%2720180618080527%27

The values of ContextId, AlertTypeId, Comment and ConfirmTimestamp should be filled with correct values. The Focused Run document AEM - Inbound Connector for Third-Party Monitoring Tools has the details about this web service.

SAP Solution Manager

As soon as monitoring and alerting data is collected in SAP Solution Manager, alerts can be forwarded to third-party ITSM systems either automatically or manually.

Outbound from Solution Manager to Third-Party System:

  1. BADI Implementation: before an alert can be forwarded to a Third-Party system, the BADI BADI_ALERT_REACTION has to be implemented and set to active. The Solution Manager guide MAI Alert Consumer BAdI Interface contains the detailed information about the alerts and how to implement this BADI. Inside this BADI one has to implement ABAP codes which call the web service provided by the customer to create an event or case on the Third-Party system. Note that each customer may have their own implementation of inbound web service even though they use the same product (e.g. ServiceNow, Remedy, etc.).
  2. Once the BADI is implemented, it can be found in the configuration of Third-Party component on the global/template/alert level. After it is set to active with the BADI implementation, alerts can be automatically forwarded to the Third-Party system.

Inbound from Third-Party system to Solution Manager Alert:

SOAP web service definition SAP_SOLMAN_ALERT_INBOX is available in SAP Solution Manager to allow Third-Party system to write comments to an alert or confirm an alert.  The web service configuration is executed in transaction SOAMANAGER. Please refer to the document MAI Alert Consumer BAdI Interface.

See Also

Knowledge base Articles:

Keywords

OCC; Operations Control Center; CCOE; Customer Center of Expertise; E2EHO; SFSF; SuccessFactors; Cloud Operations; Cloud Monitoring; Integration Management; Interface Management; ITSM Integration; Focused Run Integration; Solution Manager Integration; Event Management/Incident Management Integration , KBA , XX-SER-MCC , Mission Control Center - Knowledge Management , How To

Product

SAP SuccessFactors HCM Core all versions