SAP Knowledge Base Article - Public

3011117 - SAP SuccessFactors Operations Best Practice: Business Process Monitoring

Symptom

You operate SAP SuccessFactors and want to know about SAP Best Practice Cloud Operations. You want to establish efficient and effective Business Process Operations of this cloud solution.

Environment

SAP SuccessFactors (SaaS)

Reproducing the Issue

You need to design, adjust, or otherwise establish Business Process Operations for your SAP SuccessFactors environment.

Cause

SAP Best Practice Cloud Operations are not yet followed.

Resolution

Business Process Monitoring provides real-time monitoring of Business Process as well as Business Process Step related process performance and key performance indicators.

Goal

Ensure the healthiness of business process and steps of business services and detect anomalies of process executions.

Background

Business Process Monitoring provides real-time monitoring of Business Process KPIs based on pre-delivered sensors, which are implanted into the business logic of the considered cloud service or on-premise application. These Business Process KPIs indicate the healthiness of the underlying business process and help to understand anomalies during process execution. Business document detail information is provided, which allows analysis of critical situations. Furthermore, the impact of technical disruptions to business processes become visible, so that line of business (LOB) users and/or IT users can be notified.

The operation platform allows to retrieve business related information from different cloud services and systems and bring it in one centralized view. Our target to make the default configuration of business process monitoring as automated as possible to avoid time and resource intense business process modelling and instrumentation. Business Process Monitoring will be complemented by Process Mining as well as Process Visibility. Business Process Monitoring is relevant for cloud centric as well as for hybrid customers. It addresses the needs of LOB users.

The following business process key figures and monitoring metrics are available for SAP SuccessFactors.

1 SuccessFactors (Full Cloud)

Full cloud means that all HCM processes are executed and mastered in a cloud environment, and no master data replication is required to any on-premise systems. This would mean Core HR Master Data is maintained in SuccessFactors Employee Central, and Payroll and Time Management are also maintained in cloud solutions, such as Employee Central Payroll, Employee Central Time Management, Kronos, or Workforce Software. The following are the tools that are available for monitoring SuccessFactors jobs.

1.1 Monitoring Tools in Employee Central

1.1.1 Monitor Jobs

The Job Monitor captures jobs related to SuccessFactors Employee Central and metadata framework (MDF). This tool can be used to monitor jobs that you submit through Admin Tools > Import Data. In Admin Tools > Monitor Job, you will see the Job Status, the Submission Time and Job Details. From here you can click to download the jobs execution information to see how many successful and failed records. Not all jobs are captured in the Job Monitor.

Note: Jobs can fail and then be recovered at later points in time by the system automatically. This can happen for a number of reasons, such as there was an issue on the data center, or the job scheduler, or even because there was scheduled maintenance. When a job fails, it will be recovered and rescheduled at a later time. This can be viewed in Provisioning > Monitor Jobs. The status will either be Failed (where the job was just canceled, usually because another instance of the job is running) or the status is Recovered, which means it failed for unknown reason, and was recovered and rescheduled to run at a later time.

1.1.2 Scheduled Jobs

Scheduled Jobs Reporting Tool allows customers to self-serve and re-run/re-submit certain jobs in Admin Center. The tool supports reporting on the success/failures of scheduled jobs, which are configured in SuccessFactors Provisioning by SAP or an Implementation Partner. A scheduled job is an asynchronous, unattended program execution that runs in the background, at a predefined time or triggered by a certain event in the system. This tool currently only supports FTP/SFTP Jobs. For more information about the Scheduled Jobs Reporting Tool and how to access it, see the following SAP Help pages:

1.2 Monitoring Tools in Compensation

The Compensation Job Monitor is used to review the status of all Compensation activity jobs running in the system.

1.3 Monitoring Tools in Onboarding

1.3.1 Onboarding Audit Trail

The Onboarding Audit Trial stores all Onboarding activity. This tool is accessed through the Onboarding > Settings > Audit Trail. From the Audit Trail, you can create reports on Onboarding system activities, such to check on New Hire Activities, find user history, see users that have been deleted, or to see when someone has modified an Onboarding Panel. The Audit Trail Tool is Organized by EveYou can also use the Audit Trail to monitor the status of the Integration between SFSF and BizX if you suspect any potential failures. The Audit Trail lists the onboarding Event, which can be helpful when narrowing through results, examples of such events include as STEP_PHV_START, EMAIL_SENT,  SF_INTEGRATION, INTEGRATION_PROC, and so on. The Object ID is also listed in the Audit Tool, and for New Hire Activities, this would be the same as the Onboarding Candidate Info Object’s KMSid. For details on some of the specific activites you can search for in the Audit Trail, please review the following Documentation and Knowledge Base Articles:

 2 EC Master-Data Replication (Core Hybrid System Landscape)

Core Hybrid HCM means that Employee Central is used as the system of record holding the employee data and reporting lines of all employees, but existing processes such as Payroll, Time Management still run in an SAP ERP HCM system landscape. To facilitate the Core Hybrid HCM deployment option, you set up a regular replication of organizational and employee master-data from Employee Central to SAP ERP HCM. Following are the tools that are available for monitoring data replication from Employee Central to the SAP ERP HCM system:

2.1 Monitoring Tools in Employee Central

2.1.1 Employee Central Data Replication Monitor

Employee Central provides an admin tool for monitoring data replication to the SAP ERP HCM system. The integration processes update the status in the Employee Central Data Replication Monitor by sending notifications and confirmations. Use the Data Replication Monitor to check the replication status, view alerts, and analyze error messages related to data replication from Employee Central to SAP ERP HCM. For more information, see the Employee Central Data Replication Monitor Administration Guide.

2.1.2 SFAPI Audit Log (Monitoring Employee Master-Data Requests)

Employee Central Compound Employee API (CE API) is provided specifically for extracting employee data (including organizational assignments) out of Employee Central. You can monitor the SFAPI using the SFAPI Audit Log. To access the SFAPI Audit Log, go to the Admin Center and choose the SFAPI Audit Log tool. The Audit Log page will show the last 10,000 API calls to this system. For each call, you can view the payload of data sent. To view the payload information, in the log table select the button under the SOAP or HTTP columns. You will see the SOAP payload, or the HTTP payload details. For more information about the SFAPI Audit Log and how to access it, see the SuccessFactors HCM Suite SFAPI Developer Guide.

2.1.3 OData API Audit Log (Monitoring Organizational Data Requests)

OData API Audit Log is used to monitor OData API calls to Employee Central. You can filter, display, and download the transaction history of OData APIs using the OData API Audit Log tool. In the context of organizational data replication, OData APIs are used to retrieve data for generic objects from Employee Central. To access the OData API Audit Log, go to the Admin Center and choose the OData API Audit Log tool. The Audit Log page will show the last 10,000 OData calls to this system. For each call, you can view the payload of data sent. To view the payload information, in the log table select the button under the HTTP or REST columns. You will see the HTTP payload, or the REST payload details. For more information about the OData API Audit Log and how to access it, see OData API Audit Log in the SuccessFactors HCM Suite OData API Developer Guide.

2.2 Monitoring Tools in the SAP ERP HCM System

2.2.1 Web Service Utilities

Web Service Utilities are used to monitor incoming SOAP messages in the SAP ERP (ECP) system. Web Service Utilities (transaction SRTUTIL) in SAP ERP HCM offers an Error Log and a Message Monitor tool. Depending on your system configuration, the SRTUTIL transaction might not be available. If it's not, use the Integration Engine: Monitoring (SXMB_MONI) transaction instead.

Message Monitor can be used to analyze errors in incoming SOAP messages or check the content of messages. In case of error, we need to analyze the error log. Refer to RCA document for error analysis. We can also use the message monitoring, to analyze the Employee Central data payload received through the interface. The Message Monitor shows you an overview of all received messages along with their content in the following manner:

  • Specify the execution time in Timestamp fields on the Selection tab (find the timestamp from the SFAPI Audit Log and OData API Audit log).
  • Open a SOAP message to see the content that was transferred from Employee Central.
  • Choose Original XML to display the content in the XML format. In the XML format, we can see the data sent from Employee Central and verify this for consistency.

 2.2.2 Application log in SAP ERP HCM

An application log is written when the incoming messages are processed and stored as replication requests in the staging area, as well as when the entries in the staging area are being processed. Using the application log, you can analyze the incoming messages for replication from Employee Central in your SAP ERP HCM system in the following manner:

  • Go to the Analyze Application Log (SLG1) transaction
  • Enter the PAOC_SFI_OM (for org data replication) as object and one of the following sub-objects:
    • REPL_REQ_PROCESSING for the log created by the replication to the SAP ERP HCM system
    • REPL_REQ_PROXY for the log created when processing the inbound message in SAP ERP HCM
    • Enter the PAOC_SFI_PA (for org data replication) as object and one of the following sub-objects:
      • EE for employee master data replication
      • EE_P2P for employee master data data replication (EC Payroll only)
      • EE_TIME for timesheet/time off replication
      • EE_TIME_P2P for timesheet/time off replication (EC Payroll only)
      • Make additional selections as suits your requirements and choose Execute.

2.2.3 Advanced Replication Request Monitor

The Replication Request Monitor (SFIUI_A_REPL_REQ_MONITOR) is a Web Dynpro application that allows you to check replication requests for organizational objects and organizational assignments in all details, analyze error messages issued by the replication from Employee Central, and process replication requests manually. The SFIUI_A_REPL_REQ_MONITOR Web Dynpro application is assigned to the role menu of the SAP_HR_SFIOM_PROCESSING role in SAP ERP HCM. You can also add it to the SAP SuccessFactors user interface using the Configure Custom Navigation Admin Tool in Employee Central. This tool allows you to add hyperlinks to various locations in the SAP SuccessFactors UI, enabling users to navigate from that location to the specified URL. The URL you need to add is:<protocol><host name>/sap/bc/webdynpro/sap/sfiui_a_repl_req_monitor.

2.2.4 Replication Request Viewers

The Replication Request Viewers can access the staging areas for organizational data in SAP ERP HCM to check statuses or process requests manually.

  • Organizational Objects (Object type O, S): Replication requests for organizational objects are stored in a staging area in the SAP ERP HCM system. To view the requests, go to the Display Organizational Object Replication Requests (SFIOM_VIEW_ORG_REQS) transaction.
  • Organizational Assignments (Position to Employee Relationships): Replication requests for employee organizational assignments are stored in a staging area in the SAP ERP HCM system. To view the requests, go to the Display Employee Org. Assignment Replication Requests (SFIOM_VIEW_REQUESTS) transaction.

 3 Monitoring Objects, Key Figures, and Categories

Business Process Monitoring (BPMon) in SAP Solution Manager enables the proactive and process orientied alerting for issues that could potentially disrupt the flow of your core business processes. Purpose is to get quicker visibility about which issues occur within your solution landscape, what impact they have on the business process execution and to solve them before the business department even notices that something went wrong. SAP Solution Manager provides a central and automatic tool for Business Process Monitoring. It reduces manual monitoring efforts and allows a solution wide overview about the status of business processes.

SAP Solution Manager Business Process Monitoring

Main target group is the Operations Control Center (OCC, part of the Customer Center of Expertise (CCOE)) that centrally reacts to alerts via Event Management process(es). The OCC members work with the Alert Inbox to acknowledge alerts, execute guided procedures to solve the alert situation, and distribute alerts to other parts of the support organiztion in case the alert situation requires expert knowledge via case Management process(es).

SAP Solution Manager Business Process Monitoring

To date, the following SuccessFactors key figures/monitoring metrics are available.

Monitoring Object

Key Figure

Category

Success Factors – Job Requisitions

Job requisitions created

Throughput

Job requisitions with applications

Backlog

Job requisitions without applications

Backlog

Job requisitions closed

Throughput

LT: Job requisition -> first application [days]

Lead Time

LT: Time to Fill from SF [days]

Lead Time

LT: Job requisition -> hiring (Time to Fill) [days]

Lead Time

Job requisition creation to applicant hired (Time to Fill)

Process Progress

Success Factors – Applications

Job applications created

Throughput

Job applications in status 'applied'

Backlog

Job applications in status 'not applied'

Backlog

LT: Time to Hire from SF [days]

Lead Time

LT: Job applications -> hiring (Time to Hire) [days]

Lead Time

LT: Job application -> first offer [days]

Lead Time

Job application creation to applicant hired

Process Progress

Success Factors – Job Offers

Job offers created

Throughput

Job offers expiring in x days

Backlog

Job offers expired

Backlog

LT: Job offers creation -> expired

Lead Time

SuccessFactors - Candidates

Candidates created

Throughput

Find further information about the above and further SAP SuccessFactors Key Performance Indictors (Business Process Monitoring key figures) in the KPI Catalog.

For details about SAP Solution Manager Business Process Monitoring usage, see SAP Help Portal.
For details about SAP Solution Manager Business Process Monitoring configuration, see SAP Community Portal.

See Also

 Knowledge base Articles:

Keywords

OCC; Operations Control Center; CCOE; Customer Center of Expertise; E2EHO; SFSF; SuccessFactors; Cloud Operations; Cloud Monitoring; Business Process Operations; Business Process Monitoring; Solution Manager; Cloud ALM , KBA , XX-SER-MCC , Mission Control Center - Knowledge Management , How To

Product

SAP SuccessFactors HCM suite all versions