SAP Knowledge Base Article - Public

3011148 - SAP SuccessFactors Operations Best Practice: Workflow Management

Symptom

You operate SAP SuccessFactors and want to know about SAP Best Practice Cloud Operations. You want to establish efficient and effective Workflow Management of this cloud solution.

Environment

SAP SuccessFactors (SaaS)

Reproducing the Issue

You need to design, adjust, or otherwise establish Workflow Management for your SAP SuccessFactors environment.

Cause

SAP Best Practice Cloud Operations are not yet followed.

Resolution

Workflow Management allows for the documenting, planning, scheduling, and execution of workflows, involving the distribution of tasks and joint subsequent completion of tasks in a defined and guided manner.

Goal

Ensure that workflows are documented, scheduled, and governed - to automate workflows and task execution (ITIL: Service Configuration/Validation).

SuccessFactors Workflows

You can define workflows to set up approval processes for changes that any user makes to an employee's data. The system does not process the change until the approver approves the request. The administrator defines which changes to an employee's data trigger an approval workflow, and who needs to approve the change.

Manage Workflow Requests

The Manage Workflow Requests Admin Center tool is used to centrally review and act upon workflow requests. To view this tool, go to the Admin Center > View Pending Requests. Here you can look for any requests that might be stalled due to inactive workflow approvals, or if an initiator has left the company. Here you may change the approver, decline the request, or cancel a request. See the following guides:

Admin Alerts

The Admin Alerts dashboard in the Next Gen Admin Center provides a section of Stalled Workflow Requests. Here you can view Stalled Workflows listed by the approver they are stalled at. From the Configuration button on this tile, you can enable this section and determine the settings for which to display stalled workflows – the number of days that the workflow is stalled, and employees with X or more number of workflows. See the following KBAs:

SuccessFactors Check Tool

The SuccessFactors Check Tool can be used to identify any hidden configuration issues or data consistencies. If you are noticing system is not behaving as you expect it to, or you are experiencing issues, you may reference the Check Tool to try to identify a problem before creating an SAP case, saving time. The way the Check Tool works, you can select either one specific check to run, all the checks for a given category, or more than one category at once. From there, the tool would identify a list of issues in your configuration or data and the severity of each issue. It would also provide a solution or recommendation to address the issue. Additional use cases are introduced for the Check Tool with each release. See the following KBA:

There are several workflow related checks in the Check Tool. Please review the worklow section of the Check Tool to identify cases that can be cleaned up – such as pending approvals for completed or canceled workflows, pending approvals without a workflow, or pending approvals for inactive users.

See Also

Knowledge base Articles:

Keywords

OCC; Operations Control Center; CCOE; Customer Center of Expertise; E2EHO; SFSF; SuccessFactors; Cloud Operations; Cloud Monitoring; Workflow Management , KBA , XX-SER-MCC , Mission Control Center - Knowledge Management , How To

Product

SAP SuccessFactors HCM Core all versions