SAP Knowledge Base Article - Public

3011149 - SAP SuccessFactors Operations Best Practice: Data Management

Symptom

You operate SAP SuccessFactors and want to know about SAP Best Practice Cloud Operations. You want to establish efficient and effective Data Management of this cloud solution.

Environment

SAP SuccessFactors (SaaS)

Reproducing the Issue

You need to design, adjust, or otherwise establish Data Management for your SAP SuccessFactors environment.

Cause

SAP Best Practice Cloud Operations are not yet followed.

Resolution

Data Management ensures persistence and integrity of data as well as data interoperability and data volume management.

Ensure that data models and storage are documented, data volume is monitored and analyzed, initial and delta data loads are governed and logged – error situations being resolvable by repeated loads not leading to permanent data inconsistencies.

  • Employee Central Imports: With Employee Central Imports, Customers can efficiently perform tasks like bulk importing new employee data to the system, migrating existing employee data from an on-premise HCM solution to Employee Central, or managing large-scale changes to HR data. Since maintaining all sorts of information isn’t feasible due to cost constraints, Employee Central Imports facilitates maintenance of employee data such as:
    • Basic User Information
    • Employment Information
    • Job Information
    • Compensation Information
    • Personal Information
    • Termination Information

   The best practices for importing employee master-data are documented in the following KBAs: 

The Employee Central Imports Guide also documents vital information for using the Employee Central imports. Please refer to the chapter "FAQs: Importing Data" which is by far the best resource to answer all of Customers Employee Central Core import questions.

  • Metadata Framework Objects Import/Export Data: The Metadata Framework (MDF) is a platform that can be used to build new applications to add to customers‘ SuccessFactors solution or to modify out-of-the-box SuccessFactors applications that have been built using MDF to fit custom requirements. With MDF, customers can create and manage database object definitions, object relationships, and object hierarchy. MDF is tightly integrated with workflow, rules engine, and reporting. MDF also integrates with role-based permissions (RBP) — the recommended security layer for SuccessFactors HXM Suite. This means Customers can leverage RBP roles to secure  customer's objects and data. The MDF supports import and export functionalities to manage the data for custom objects as well as the standard MDF objects. Details on the techniques for using import/export functionalities can be found in the following KBAs:

    • Check Tool: The SuccessFactors Check Tool can be used to identify any hidden configuration issues or data consistencies. If you are noticing system is not behaving as you expect it to, or you are experiencing issues, you may reference the Check Tool to try to identify a problem before creating an SAP case, saving time. The way the Check Tool works, you can select either one specific check to run,  all the checks for a given category, or more than one category at once. From there, the tool would identify a list of issues in your configuration or data and the severity of each issue. It would also provide a solution or recommendation to address the issue. See KBA - Check Tool: How to check your SuccessFactors configuration.

      The following are some of the important checks available in the Check Tool that you may run periodically to identify any data inconsistencies:

      • Employee Central Core – Bank Information – check to ensure there is no duplicate bank information in the system
      • Employee Central Core – Compensation – checks to ensure there are no data inconsistencies related to critical compensation data
      • Position Management – Data Consistency – check to ensure all mandatory fields have been maintained for all active position records
      • User Management – User Hierarchy – Check that no manager cycle exists in the system
      • User Management – User Information – Check for duplicate e-mail addresses and check for duplicate usernames

    See Also

    Knowledge base Articles:

    Keywords

    OCC; Operations Control Center; CCOE; Customer Center of Expertise; E2EHO; SFSF; SuccessFactors; Cloud Operations; Cloud Monitoring; Integration Monitoring; Interface Monitoring; Data Consistency Management; Data Monitoring , KBA , XX-SER-MCC , Mission Control Center - Knowledge Management , How To

    Product

    SAP SuccessFactors HCM Core all versions