SAP Knowledge Base Article - Public

3011164 - SAP SuccessFactors Operations Best Practice: Application Monitoring and Metering

Symptom

 You operate SAP SuccessFactors and want to know about SAP Best Practice Cloud Operations.

Environment

SAP SuccessFactors (SaaS)

Reproducing the Issue

 You need to design, adjust, or otherwise establish Application Monitoring and Metering for your SAP SuccessFactors environment.

Cause

SAP Best Practice Cloud Operations are not yet followed.

Resolution

Application monitoring provides application specific insights in cloud services and systems, including background job/business process automation monitoring, end-point availability monitoring and performance monitoring, configuration and change monitoring, access and security monitoring, usage monitoring and metering as well as potentially further aspects. This ensures the healthiness of the application processing and measure the basic quality of service as well as usage.

Application monitoring delivers application specific insights in cloud services and systems. Basically, it monitors aspects which are not covered by one of the dedicated monitoring use cases as Business Process Monitoring, Integration Monitoring, User Monitoring and System, DB and Host Monitoring. Several aspects are essential:

Job Monitoring

For background jobs it needs to be ensured, that it is running in a certain time window or that it is starting at a certain point in time. In addition, the responsible person needs to be informed in case job execution fails.

Availability Monitoring

For services it needs to be ensured that availability is checked, for SAP as well as non-SAP cloud services and systems. Relevant are URL checks, URL certificate checks, TCP/IP checks, OS process checks, RFC checks, and Windows Service checks. We plan to incorporate availability information for cloud services provided by SAP Cloud Availability Center. In addition, general healthiness checks for cloud services become more and more relevant.

Exception Monitoring

For every system and solution component it needs to be ensured that relevant single exceptions are exposed by the managed cloud service or system. This allows to notify end user via integration in Event and Alert Management on a single exception level or exception bulk level.

Performance & Usage Monitoring

For every system and solution component it needs to be ensured that User Monitoring or Integration Monitoring are covered especially for performance aspects. In the context of Application Monitoring we refer to aggregated performance & usage information which allow trend analysis and capacity evaluations.

The different Application Monitoring use cases are relevant for cloud centric as well as for hybrid customers. It addresses mainly IT users, however, also LOB users may be interested in some aspects e.g. cloud service availability or business related exceptions. Refer to the Knowledge Base Articles below to find recommendations for SuccessFactors system and solution landscapes.

See Also

SAP knowledge Base Articles:

Keywords

OCC; Operations Control Center; CCOE; Customer Center of Expertise; E2EHO; SFSF; SuccessFactors; Cloud Operations; Cloud Monitoring; Application Operations; Aplication Monitoring , KBA , XX-SER-MCC , Mission Control Center - Knowledge Management , How To

Product

SAP SuccessFactors HCM Core all versions