Symptom
Users cannot see Story reports listed in Report Center.
According to the Help Guide, as long as a Story is shared with a user, it should appear in their Report Center. They would not require any additional Role-Based Permissions (RBP) to view or run them. RBP access is only required for users who need to create Story reports.
Environment
SAP SuccessFactors HCM Suite
- Analytics & Reporting (Ad Hoc, YouCalc, ORD)
- Report Centre
- Report Centre Listing & SOLR Issues
- Report Centre
Reproducing the Issue
- Login as the affected user
- Navigate to Report Center
- Try to filter by Report Type = Story
- No Story reports are visible even though a number of reports already exist in the instance
Cause
- User was not successfully synced/created in SAC with correct details
- Report was not Shared to non-Story Admin user (affected user)
Resolution
In order for users to see Story reports the following are required:
1. User should be synced to and exists in SAC server.
You can always check if a specific user was successfully created in SAC through the Check Tool:
2994478 - How to Check if a User exists in SAC for accessing Story reports in SuccessFactors - SAP for Me
Other useful references related to User Sync in IPS:
2. Please ensure that the Story is Shared to the specific non-Admin user with at least Read rights granted.
Users who have no Create Story nor Story Admin permission will not see all Stories by default so the reports must be Shared with them.
Please see Sharing a Story Report
"As an author, you can share stories that you've created, and as a Story admin, you can share any story in the instance. When you share stories with Story admin users, by default, they have the permission to perform any action on the story irrespective of the access you grant. However, when you share stories with the non-admin users, you can grant read, edit, or full access to the shared report.
3. If the above is provided and the users are still not able to see Stories listed, then try the following:
-
- Refresh certificates:
- Login to provisioning and navigate to "Configurations for Stories in Story Reporting" tab
- Run 'Refresh and Regenerate SAC OAuth Configurations'
- Reports missing in Report Center
- Refresh certificates:
If the above does not work, please open a ticket, with SAP Support, with component LOD-SF-ANA-RCT-SAC
See Also
Keywords
Stories not listed, story reports missing, cannot see Story in Report Center, Stories missing, Shared story, shared story report, is not visible, cannot see Stories, non-Story admin, story admin , KBA , LOD-SF-ANA-RCT-LST , Report Centre Listing & SOLR Issues , LOD-SF-ANA-RCT-SAC , People Analytics Stories , Problem
SAP Knowledge Base Article - Public