SAP Knowledge Base Article - Public

3013272 - New Button Is Grayed out While Trying To Create A New Ticket From Contract

Symptom

New button is grayed out while trying create a new Ticket in the Tickets tab of Contract.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Contracts work center
  2. Open the Contract XYZ (Where XYZ indicates the Contract ID)
  3. Go to Tickets view
  4. The New button is grayed out

Cause

The contract is In Preparation status.  The Contract should be in Active status for the New button to be enabled.

Resolution

To activate the Contract, the Begins On date must be set to the current date. If the Begins On date of the Contract is in the future, then the Contract remains in the status Ready until the Begins On date is reached. A background job changes the status to Active automatically once the Begins On date is reached.

Once the status of the Contract is changed to Active, the New button gets enabled.

See Also

 KBA 2638588 - Contract Status Does Not Change From Ready To Active

Keywords

Contract, Ticket, New, Active, In Preparation, Button, Grayed Out, Read , KBA , contract , button , ticket , new , LOD-LE-COP , Contract Processing , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions