SAP Knowledge Base Article - Public

3013470 - SAP S/4HANA output control - Issues with output

Symptom

Output has been triggered from a business application but it resulted in errors or no output.

The corresponding output items show status Error and the message log shows messages like:

a) Error(s) occurred when saving the document to KPRO.
A technical error occurred when saving the output document to DMS.
Error when trying to access KPRO file storage (Save Not Allowed).

b) SOAP Framework error: SOAP:1023 SRT: Processing error in Internet Communication Framework: ("Connection to partner timed out after 7200s.")(100,106).

The corresponding output items show status Completed but no output is performed.

c) No email has been sent.

d) No documents are send to the printer.

e) Output items are not processed and seem to be stuck in status To Be Output.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

Trigger an output from a business application.

Cause

Related services are temporary unavailable or have issues.

The root cause needs to be found and fixed by the corresponding component.

OM_Architecture_Support_Components_Customer (002).png

Resolution

1. As many of the issues can be caused by temporary unavailability of related services, the first recommendation is to retry the output (via action Retry) – see KBA 2861070. Only if the issue persists, an case can be opened on the corresponding component. See information below for the correct component.

2. Analysis of the underlying issues:

Symptom a) - Problems saving the documents:

  • Please open an case on component BC-SRV-KPR for the document service and provide the timestamps from the output message log.
  • Ask whether there was an outage of the service at this time.

Symptom b) – SOAP errors during form rendering:

  • Please open an case on component XX-S4C-OPR-INC for the Cloud Operations.
  • Ask to check the corresponding Adobe Document Services.

Symptom c) - Sending emails is not working:

  • Open the Display Email Transmission app via SAP Fiori launchpad.
  • If the status of an email is Error or Waiting, please open an case on component XX-S4C-OPR-INC.

Symptom d) - Printing of documents is not performed:

  • When the output item shows status Completed, the corresponding print queue item was successfully created in the print queue.
  • Printing on the physical printer is then up to the SAP Cloud Print Manager (CPM), installed on the customer/client side. The CPM might not be set up properly or faces technical issues when connecting or pulling documents from the SAP S/4HANA Cloud system.
  • Make sure the CPM is up and running with the correct user credentials. Test the connection.
  • If the errors persist, please open an case on component BC-CCM-PRN-OM-PM to check if there is an error in print queue or client print software itself.
    Attach the log.txt file of the CPM that can be found here: C:\Users\<CPM User>\AppData\Roaming\SAP\Cloud Print Manager\Printing

Symptom e) – Output seems to be stuck in status To Be Output.

See Also

KBA 2861070 - SAP S/4HANA output control - How to restart stuck output

Monitor output with Manage Output Items app

Monitor erroneous output with user-specific notifications

2941522 - Output Management in SAP S/4HANA Cloud - Guided Answer

3063524 - Error handling when experiencing printing issues - SAP S/4HANA Cloud

3274509 - Emails do not reach the recipients - SAP S/4HANA Cloud

3265907 - Output Items of Email channel are completed but emails does not reach recipient - S/4HANA Cloud

3223182 - Mandatory DKIM setup - SAP S/4HANA Cloud 2208

Keywords

BRF+, 1LQ, KPRO, SOAP, PRINT, EMAIL, Manage Output Items, Display Email Transmission, To Be Output, erroneous output, output issue, technical errors during output , KBA , CA-GTF-OC , SAP S/4HANA output management , BC-SRV-KPR , Knowledge Provider , BC-SEC-VIR , Anti Virus Protection , BC-CCM-PRN-OM-PM , S/4HANA Output Management Print Manager , BC-NEO-ECM-SER , Document Center - Server, Web App, AdminUI , BC-SRV-FP-NEO , Adobe-Interactive-Forms-Cloud-Wartung, Neo , BC-SRV-FP-OM , Output Management: Form Services , XX-S4C-OPR-INC , S/4HANA Cloud Availability, Performance and Administration , Problem

Product

SAP S/4HANA Cloud Public Edition all versions