SAP Knowledge Base Article - Public

3014376 - Picklist Center - Duplicate Inactive Picklist Values with Same Label Showing for Historic Candidates

Symptom

Inactive Picklist Values are showing in Picklist dropdown for Historic Candidates.

Environment

SAP SuccessFactors Recruiting Management

Cause

New Picklist value were created with the same picklist labels.

Resolution

If the same picklist label is required, it is recommended to change the picklist label rather than inactivating the current picklist value and generating a new option ID. Creating a new picklist option ID with the same label can cause a data issue where inactive picklist values may be visible to existing candidates who have already provided a value in the picklist in the previous applications.

Note: It is important when setting up Business Rules on the Country field, that you follow the process outlined above. Otherwise, there may be issues with executing the rule correctly as the system will struggle to differentiate between the active and inactive Picklist options, which both share the same Picklist label.

Keywords

Option ID, duplicate, label, value, active, inactive, picklist center, picklist management, candidate, application, business rules, rule, country , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions