Symptom
Get Appointment, in Tickets, does not return any values and show message 'No Slots for Technician', even thought there are Employee free at that time.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Select the Tickets view.
- Open Ticket ID 123 (123 represents the Ticket ID that has a valid Item for Scheduling).
- Go to the Items tab.
- Select Line Item 10 (Line Item is the one ready for scheduling).
- Click on Appointment.
- Select the Date and Appointment Type.
- Click on Get Appointment.
- No Slots for Technician.
Cause
There are three requirements for the Appointments to be shown:
- Ticket 123 must have a Service Technician Team maintained.
- On this Service Technician Team, there must be at least one Employee available at the time selected.
- On this Service Technician Team, there must be at least one Employee with the Mandatory Skills maintained.
Resolution
This is the expected system behavior.
Keywords
resource scheduler ; service and repair ; technician ; assignment ; material ; expense , KBA , LOD-CRM-IND-IMC , Industrial Machinery & Components , How To
Product
SAP Cloud for Customer core applications all versions