SAP Knowledge Base Article - Public

3016649 - Error: "Document Already exists"

Symptom

You replicate a attachment to C4C and the error "Document Already exists" is raised on Web Service Message Monitoring.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Replicate one Attachment to C4C using the Standard Integration Interfaces.
  2. The error  "Document Already exists" is raised on the SAP Cloud for Customer Web Service Message Monitoring.

Cause

Under the Payload of the Message ID where the Error was raised you should search for the Tag "<Document><Name>"

Notice that you have multiple files with the same Name. This happens in the case you send two files with same filename and different extensions.

Example:

FileName1.docx

FileName1.msg

Unter the XML Tag <Name> the Extension will be ignored and the Name will be filled with just the filename.

This will make the error: "Document Already exists" being raised.

 

Resolution

Ensure that you have no Filenames filled with same name on the Message you are sending to SAP Cloud for Customer.

Keywords

"Document Already exists" , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications 2011