Symptom
The New Hire Activity for a candidate shows an error when reviewing the New Hire Activities tab.
Error: User Data for New Hire inconsistent. Please contact your administrator. ProcessId:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
Navigating to New Hire Activities:
- Navigate to Onboarding
- Click on New Hire Activities tab (If the NHA tab is not enabled, please follow KB article 2789202 to enable this option.)
- Locate the candidate in question
- The error below shows for candidate with a processID number (example below)
Cause
- The New Hire Activities (NHA) feature pulls information from UDF object.
- Missing information for the candidate there would cause the error to show in NHA.
Resolution
To locate missing information that may be causing the error in NHA:
- Copy the ProcessId showing for the candidate in NHA
- Go to Manage Data
- Select in Search the OnboardingProcess object
- In the field next, enter the ProcessId
- Review the information in the contact card icon next to UserID
- Any missing information here, such as the first or last name, would cause the inconsistence and as a result the error would show in NHA.
- The system is working as designed. The New Hire Activities feature pulls information from the UDF object, which is filled with the current information from the candidate.
- If different functionality is desired in a future release, our recommendation is to log an enhancement request as described in KB article 2302363.
See Also
KB article 2302363 - How to Submit An Enhancement Requests for Onboarding
Keywords
SF, success factors, ONB, OBD, on boarding , KBA , LOD-SF-OBD-NHA , New Hire Activity , Problem
Product
SAP SuccessFactors Onboarding all versions
Attachments
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