Symptom
When setting the "Allow All Origins" option in SAC under the Administration section (or in SAP Datasphere), it doesn't allow all origins and the following error message is shown;
- "Server error. Please try again."
- In the Google Chrome Developer Tools Network tab, the following is shown;
{status: 400, message: "Invalid request form"}
message: "Invalid request form"
status: 400
Environment
- SAP Analytics Cloud (Enterprise) 2021.05
- SAP Datasphere
Reproducing the Issue
- Login to SAC and go to System->Administration->App Integration
- Check off the option "Allow All Origins" under the section "Trusted Origins"
- Note that all origins are not allowed
Cause
The ability to set all domains as trusted has been removed. The removal was done on the back end first and a UI update will be done in a later wave.
Resolution
To resolve this issue you must set a list of specific origin sites that are allowed.
- Logon to SAC with an administrator account
- Navigate to the menu > System > Administration
- Select the App Integration tab along the top, scroll to the bottom
- Under "Trusted Origins", ensure "Allow All Origins" is unchecked
- Use the "Add A Trusted Origin" to create the allowed list of domains you trust
Note: If the embedding tool is using a specific port number, then please specify the port number in the trusted origin as well.
For Datasphere you will also need to add the specific SAC tenant as a Trusted Origin in DS.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, Origins, Integration, trusted , KBA , LOD-ANA-AUT , SAC Authentication / Login , LOD-ANA-ADM , SAC Administration , DS-ADM , Administration , Problem