SAP Knowledge Base Article - Public

3018088 - Purge completed with an empty report - Onboarding

Symptom

You have executed a purge request for DRTM Onboarding Purge, however, the purge request is being completed with an empty report.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.  

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Go to Admin Center > Data Retention Management;
  2. In Manual Data Purge, click in Create New Purge Request;
  3. In Purge type select DRTM Onboarding 2.0 Purge;
  4. In process type select Onboarding or Offboarding and select the status Cancelled or Completed;
  5. Select your user to be purged and the objects to be purged.
  6. Add the approver and execute the purge;
  7. In purge monitor, you'll see a purge completed with an empty request.

Cause

An empty report means that the background purge process has completed successfully, but none of the specified user data was eligible for purging, so no data purge occurred. In this case, you need to double-check the purge criteria and configured retention time, and then submit the request again.

Cause 1: The most common cause is that the purge criteria is not matching with regards to the process status. Only closed activities (completed or cancelled) will be purged.

Cause 2: User has compensation or variable pay form. User represents the main employment tied to a person with global assignment or concurrent employment; however, not all users belonging to that person are included in the purge rule.

Cause 3: DRTM Onboarding 2.0 feature is not enabled through upgrade center hence skip criteria report generation

Resolution

Resolution 1:

  1. Setup the rule for process closure as described  Setting Up a Business Rules for Closing the Onboarding/Offboarding Processes;
  2. Make sure that this rule was executed for your users to be purged;
  3. Go to Manage Data > Process Trigger and make sure that the process status is set as Cancelled or Completed (below screenshot);
  4. Run a new purge request.



Resolution 2:

Check all the prerequisites for Data Retention Time Management.

Resolution 3:

DRTM Onboarding feature need to be enabled through upgrade center.

Support Engineer: Check internal memo for logs.

See Also

Setting Up a Business Rules for Closing the Onboarding/Offboarding Processes

Checking Job Status and Details for a Purge Request

Implementing and Managing Data Protection and Privacy

Keywords

onboarding, obx, empty, preview, report, purge, not, working, drtm, process, closed, open, incomplete, cancelled, upgrade, center , KBA , LOD-SF-OBX , Onboarding 2.0 , Problem

Product

SAP SuccessFactors Onboarding all versions

Attachments

image.png
image.png