SAP Knowledge Base Article - Public

3018134 - Unable to download data file in app "Export Master Data - Product"

Symptom

  • When exporting data in "Export Master Data - Product" error "In the context of Data Services an unknown internal server error occurred" occurs.
  • The "File is being generated" popup disappears and nothing happens when trying to export huge amounts of data in Export Master Data - Product app.
  • The "File is ready for download. Download File" popup does not appear when large data quantities are in the scope, and no errors are thrown.

Environment

  • SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the "Export Master Data - Product" app
  2. Choose "Select All Fields from All Tables"
  3. Include the Selection criteria
  4. Set File Format to "Office Open XML (*.xlsx)"
  5. Click on Export
  6. Confirm the scope of a large amount of data (e.g., >1000 Products with scope of >1000 fields) 

Cause

Memory is exhausted caused by too much data being exported.

Resolution

To reduce the memory space needed to export the master data, consider at least one of the following options:

  • Use File Format "Compressed CSV (*.zip)" to export large data quantities, as recommended in File Format for File Upload - Compressed CSV (*.zip) format | SAP Help Portal.
  • If using "Office Open XML (*.xlsx)" is necessary, adjust the selection criteria to reduce the selection scope. For example, select several ranges of Material Number (MARA-MATNR).
  • Instead of "Select All Fields from All Tables", use "Select Specific Fields" or "Select Tables" to reduce the amount of data exported.

See Also

Keywords

Resource bottleneck, SYSTEM_NO_ROLL, SESSIONMEM_QUOTA_WARNING, MEM_ALLOC_FAILED, mdm.cmd.cmpexportfiles, MARC, all fields, Business Partner extraction, F3251. , KBA , CA-MDG-CMP-MM , Material , LO-MD-MM-2CL , Product Master for Public Cloud , Problem

Product

SAP S/4HANA Cloud Public Edition all versions