SAP Knowledge Base Article - Public

3018500 - Deletion of Measurement Document Triggered from ERP to C4C Registered Product

Symptom

You notice that the deletion of Measurement Document of Registered Product, triggered from ERP to Cloud for Customer system is not working.

Environment

SAP Cloud for Customer

Cause

SAP Cloud for Customer system is missing a BTD Reference for the Measurement Document, therefore, when the deletion message comes in from ERP, the same is not processed.

Resolution

It is required to create the BTD Reference in Cloud for Customer system for the Measurement Documents created in C4C, and replicate this reference to ERP.

This can be done by using the same IDoc to send back the created Measurement Document in ERP with the C4C Measurement Document BTD Reference.

Once a deletion is sent from ERP to C4C, it will happen as expected since the BTD Reference will exist in the payload.

Keywords

Measurement Document, Registered Product, Product, RP, Service, C4C, Cloud for Customer, ERP, SAP ERP, S4, Deletion, Delete, Payload, , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions