SAP Knowledge Base Article - Public

3018591 - Campaign Field Missing for Activity tabs Appointment and Task Account, Contact and Individual Customer TI

Symptom

Campaign field not available to be added to Account, Contact and Individual Customer TI Appointment and Task activity tabs.

Environment

SAP Cloud for Customer

Reproducing the Issue

The same can be reproduced in the Account, Contact and Individual Customer TI. 

  1. Go to the Customers work centre
  2. Go to the Contacts view
  3. Open any contact
  4. Navigate to the Activities facet
  5. Enter Adaptation mode 

RESULT:

  • You cannot add the standard field "Campaign" to the sections "Appointments" and "Tasks".
  • The other two sections ("Phone calls" + "E-Mails") have the "Campaign" field available via Adaptation in the fields repository/pool.

Cause

The availability of the Campaign field for the Task and Appointment tabs in the Activity facet of the Contact TI, is dependent of scoping.

Resolution

  1. Go to the Business Configuration work centre > Implementation Projects view.
  2. Select the relevant project.
  3. Navigate to step 4, Questions 
  4. Expand: Sales > Activity Management > Activities   
  5. Review and scope the following question by checking the box and adding it to your project: 

Do you want to enable an enhanced activities facet to search and query for activities in account, contact, and individual customer workcenters?

  1.  Save your changes. 
  2.  Log out and back in.

Result: with this question scoped, the Campaign field will be available for all Activity tabs in account, contact, and individual customer TI.

Keywords

Adaptation, Consistent, Available, C4C , KBA , LOD-CRM-CON , Contact , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 2011