Symptom
Campaign field not available to be added to Account, Contact and Individual Customer TI Appointment and Task activity tabs.
Environment
SAP Cloud for Customer
Reproducing the Issue
The same can be reproduced in the Account, Contact and Individual Customer TI.
- Go to the Customers work centre
- Go to the Contacts view
- Open any contact
- Navigate to the Activities facet
- Enter Adaptation mode
RESULT:
- You cannot add the standard field "Campaign" to the sections "Appointments" and "Tasks".
- The other two sections ("Phone calls" + "E-Mails") have the "Campaign" field available via Adaptation in the fields repository/pool.
Cause
The availability of the Campaign field for the Task and Appointment tabs in the Activity facet of the Contact TI, is dependent of scoping.
Resolution
- Go to the Business Configuration work centre > Implementation Projects view.
- Select the relevant project.
- Navigate to step 4, Questions
- Expand: Sales > Activity Management > Activities
- Review and scope the following question by checking the box and adding it to your project:
Do you want to enable an enhanced activities facet to search and query for activities in account, contact, and individual customer workcenters?
- Save your changes.
- Log out and back in.
Result: with this question scoped, the Campaign field will be available for all Activity tabs in account, contact, and individual customer TI.
Keywords
Adaptation, Consistent, Available, C4C , KBA , LOD-CRM-CON , Contact , LOD-CRM-ACC , Account , How To