Symptom
When creating an Over-the-Counter Sale, you observe that the system does not show the "Cost" Price Component in the "Pricing" tab.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Over-the-Counter Sales work center.
- Open the Over-the-Counter Sales view.
- Find Document ABC (Where ABC represents the Over-the-Counter Sale ID).
- Click on the View All button.
- Navigate to the Pricing tab.
- Click the Expand All button.
You observe that the "Cost" Price Component is not maintained.
Cause
This happens in cases where the Currency is not determined in the document. The system needs to first determine the Price in the Over-the-Counter, and since the Currency is not determined, that is not possible and subsequently the Cost is also not determined.
Resolution
You need to make sure that the Currency is correctly maintained for the Account and Sales Organization used in the Over-the-Counter document. To check this, follow these steps:
- Go to the Over-the-Counter Sales work center.
- Open the Over-the-Counter Sales view.
- Find Document ABC (Where ABC represents the Over-the-Counter Sale ID).
- Click on the View All button.
- Navigate to the Involved Parties tab.
- Make note of the Account DEF and Sales Unit GHI (Where DEF and GHI Represent the Account and Sales Unit ID's, respectively).
- Open Account DEF.
- Navigate to the Sales Data tab.
- Under Sales Organization, make sure that Sales Unit GHI is maintained and that the Currency is also present in the Details section when you Highlight it.
Keywords
Over the Counter, OTC, Sales, Sales Org, Sales Unit, Cost, Price Component, Unable, Missing, Mismatch , KBA , AP-CI-CI , Customer Invoice , AP-PRC-PC , Calculation , How To