Symptom
You perform a personal data deletion of employees and encounter the error: "Veto raised by party/contact in business document ID XYZ (type Sales Order)"
(XYZ represents the Sales Order ID.)
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Data Protection and Privacy work center
- Select the respective object (All Business Partners, All Contacts, All Employees or All Private Accounts)
- Select Remove Data and select Delete
Now:
- Go to the Common Tasks view
- Select the run and open the Application Log ID
- Select the Results tab
- Expand the Error During Data Removal to see the error
Cause
The sales order has lifecycle status "in process", therefore a destruction veto is raised.
Resolution
Make sure that the sales order document gets the status "completed" and the destruction of the object in C4C will work.
Keywords
KBA , LOD-LE-BP-BP , Business Partner , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions