Symptom
You have maintained a Renewal Rule for Customer Contract which a Quote for Contract or a Contract is supposed to be created, however, nothing has been created.
Environment
SAP Business ByDesign
Reproducing the Issue
Scenario: You have set up a Renewal Rule where a Quote for Contract should be created one month before the end of Contract Validity. Contract Ends on April 30th.
On March 30th, you expect to see the Quote for Contract created:
- Go to the Sales Orders work center.
- Go to the Contracts view.
- Search for XX (XX is the Contract ID)
- Click on Edit.
- Navigate to the Document Flow tab.
- It's possible to see no Quote for Contract created.
Cause
Once you are setting up the Renewal Rule, it's necessary to select the checkbox for Auto Renew. If this is not selected, the system will not trigger the creation automatically.
Only a task reminding the Renewal Rule will be created.
Resolution
- Go to the Business Configuration work center.
- Go to the Overview view.
- Search for: Renewal and Cancellation for Customer Contracts activity.
- Select Maintain Renewal Rules.
- Confirm that in the rule created, the checkbox Auto Renew is selected.
See Also
Keywords
Renewal Rule, Contract, Quote for Contract, Auto Renew , KBA , AP-CCP-CC , Customer Contract , How To