SAP Knowledge Base Article - Public

3020667 - "The alias 12345 already exists" Error Raised When Replicating Employee from SAP Success Factors to C4C

Symptom

Employee Replication from SuccessFactors Employee Central to C4C, failing with the following error: "The alias 12345 already exists".

Environment

SAP Cloud for Customer

SAP SuccessFactors

Reproducing the Issue

  1. Go to Web Service Message Monitoring under Administrator Work center.
  2. Search for the EmployeeReplicationIn Service Interface.
  3. You will be able to see the error.

Cause

The ID being sent for the Employee already exists in the system for a different Employee/Business User. The Alias of the user ID must be unique on the system.

Resolution

In order to fix the issue, you need to make data and IDs between systems consistent.

As a workaround you can remove the linkage between existing Business User and Employee, delete existent ID Mappings and then replicate it again to C4C.

To remove the linkage between existing Business User and Employee you need to follow the below steps:

  1. Go to Administrator.
  2. Open the Business Users view.
  3. Search for the User ID.
  4. Open the User.
  5. Click on Edit.
  6. Choose Attributes.
  7. Under User Data, change the User ID to something else which should be unique and shouldn't collide with another user.

In general if there are some collisions between existing Employees to the incoming requests, we recommend you to check your replication strategies as using the same ID for different employees can actually have serious impacts on transactional data.

Keywords

Employee, Business User, Alias, ID,ObjectID,C4C. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer add-ins all versions