SAP Knowledge Base Article - Public

3020991 - Contact person's e-mail address cannot be found under the "Partner" tab in the sales order

Symptom

When creating a sales order for a business partner with business partner category "Person", the contact person's e-mail address cannot be found under the "Partner" tab in the header details of the sales order.

Environment

 SAP S/4HANA CLOUD

Reproducing the Issue

  1. Open the "Create Sales Orders (VA01)" app and input the order type. Then click continue.
  2. Input a business partner with business partner category "Person" into the Sold-To Party.
  3. Click the "Display header details" button and then click the "Partner" tab.
  4. Double-click the contact person's name and find that there is no e-mail address under the communication part.

Cause

It is standard design that for "Person to Person" contact person relationship, there is no "Address Data" part in which communication information such as Telephone, Mobile Phone, E-Mail, etc. are maintained.

Resolution

In order to have the contact person's e-mail address, please use the business partner category "Organization" instead of "Person".

  1. Go to the "Manage Business Partner Master Data" app.
  2. Click "Create" and choose "Organization.
  3. Fill in all the necessary information and click "OK".

Please pay attention that, it is not possible in the standard system to change the business partner category. You can only archive and delete the business partner and recreate a new business partner with the correct category.

Keywords

Sales Order, Business Partner, Business Partner Category, Person, Organization, Contact Person, Create Sales Orders (VA01), Sold-To Party, Communication, Relationship, Address Data, Telephone, Mobile Phone, E-Mail, Manage Business Partner Master Data , KBA , SD-SLS-SO , Sales Orders , LO-MD-BP , Business Partners , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions