SAP Knowledge Base Article - Public

3021424 - Candidates are not appearing on the Job Requisition - Recruiting Management

Symptom

  • The Candidate count is visible on the Job Requisition Summary page but when you click on it, they are not appearing on the Candidate Summary page.
  • When you click the Candidates Tab, you are receiving an error: Fingerprint id: 0c461107708a9f7b455b3faada6d9040fda25438
  • Candidate disappeared in the pipeline but visible in the report.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Log in to Bizx
  2. Go to Recruiting Tab
  3. Click the candidate count from the Job requisition Summary page
  4. Candidates are not visible

Cause

Application of the candidates are being sent to the Job requisition with an incorrect status set id or status id.

There is a third party integration which is sending the wrong information of status set id or status id of the application in the system.

(For SAP Support: please see internal memo)

Resolution

There are 2 ways how to identify the issue using reporting:

Using Integration Center

  1. Go to Admin Center >> Integration Center
  2. Click My Integrations
  3. Click Create >> Simple File Output Integration (*)
  4. Search and select JobApplication entity
  5. Select the following field names
    • Application Id (applicationId)
    • Job Application Status Item Id (appStatusSetItemId)
    • Candidate Id (candidateId)
    • First Name (firstName)
    • Last Name (firstName)
    • Job Requisition Id (jobReqId)
    • Application Template Id (applicationTemplateId)
  6. Click Configure Fields tab >> Add the following field name from the JobRequisition entity
    • Application Status Set Id (statusSetId)
  7. Click Filter and Sort tab >> Filter the Columns based on what information you have from your end
  8. Go back to Configure Fields tab to fetch the "appStatusSetItemId" (Status ID) and "statusSetId" (Status Set ID).

(*) Alternatively, please select 'Import an Integration Definition' to import the definition (.icd) file which can be obtained from the KBA attachment [JobApplication_appStatusSetItemId_Export_definition.zip]. This is a sample integration containing necessary fields.

Using table report in Report Center

  1. Create table report
  2. Select Recruiting V2 domain
  3. Select the following fields
    • Job Requisition ID
    • Application ID
    • Candidate ID
    • First name
    • Last name
    • Application Status
    • Application Status Set
  4. Filter the Report by Job Req ID
  5. In the Application status set, you will see 2 or multiple values.

The Job Requisition is linked to 1 application template and 1 status set. If you are using API to move the candidates, you normally provide the status item ID. If the status item ID is not within the linked status set, you will get the error for this application when opening.

Solution

1. Find the correct Status ID (corresponding to appStatusSetItemId in API)

  1. Go to Admin Center >> Edit Applicant Status Configuration
  2. Open the Status Set
  3. Find the Status ID of the status name

2. To correct the appStatusSetItemId, please refer to the KBA 2883239 - How to update the Application Status via Integration Center/OData API - Recruiting Management.

3. To avoid the error, please check with Implementation Partner to review the "appStatusSetItemId" provided in the API request payload used for creating/updating job applications.

Keywords

candidates, not, appearing, showing, missing, visible, job, requisition, page, summary, report, integration, center, 0c461107708a9f7b455b3faada6d9040fda25438, AppCustomizedStatus.getLocalizedInternalLable, AppCustomizedStatus, getLocalizedInternalLable, 31f15cc7e1e0dd57411a81b7fa512c6abac6f7c8, "status" is null , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-APP , Applicants and Job Applications , LOD-SF-RCM-API , Webservices & APIs , Problem

Product

SAP SuccessFactors Recruiting all versions

Attachments

JobApplication_appStatusSetItemId_Export_definition.zip